Membership Plugin email sent to manually added subscription

We manually added a subscription to a multiple of users by going to Membership->All Members and the the email configured in Membership->Communications got sent out to all the users.

This caused the users a lot of confusion.

We suggest having an option to "Do NOT send out email to manually added subscriptions". Please review and if this makes sense, send to developers for future update.

Thanks!

  • Hector Torres
    • The Incredible Code Injector

    After our last reply, we tried to bypass this issue by doing the following:

    1) We went to Membership->Communications and clicked on "Deactivate" on the email ( we only have 1 email there with Message sent to all subscriptions and sent = "after subscirption is paid" )

    2) We manually deleted the Subscription from several users by going to Membership->All Members

    3) We changed the Access Levels assigned to the subscription

    4) We added the same Subscription back to the same users by going to Membership->All Members

    5) A few minutes later we went to Membership->Communications and clicked on "Activate" on the email. The email got sent to ALL of the users mentioned in step #4 above which is what we were trying to avoid.

    This is a big problem for NEW installations where we need to add a Subscriptions to all users that existed prior to installing the Membership plugin.

    We have not tested what would happen if we delete the email in Membership->Communications and then add the subscriptions.

    Anyway, I thought this would be helpful to post and make others aware of this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.