Membership plugin issues

Hello,
I am working with the Membership plugin and Buddypress and I am trying to get the sign-up to be completed without having to turn on the standard Wordpress registration. I am using Buddypress 1.5.4 and Membership 3.0. I have 2 subscription levels for the site. One is basic which is free and the other is for visitors in which I want them to sign up in order to get the membership. I'm using it for my client to keep track of members, purchases through Marketpress and such. My problem is that when I try to sign up as a user with my membership registration page it says "User registration is currently not allowed" because of turning it off in the settings. Is there something that I'm missing? Do I need to set up a visitor privilege?

Also, when I try to view the tabs in my membership options panel they all stay on the General settings information. The tabs change but the information stays the same. But if I type in the address of what the tabs are then the content changes. I'm also using the Prestige theme, in case that helps. The repair membership says everything is ok. I'm guessing there is something I am missing. Any help would be greatly appreciated. Thanks! Matt

  • Kimberly

    Macdesgin,

    Hello and Welcome to WPMUdev forums!

    "User registration is currently not allowed" because of turning it off in the settings

    Which settings? You must allow registration in Membership to allow users to register, Membership adapts itself to use the wordpress registration. However if you have Buddypress installed, it will take over the registration process depending on your settings.

    By default your Visitor role should be the one that general visitors (i.e if I should click to visit your site and want to browse) should use with no registration. Your Free membership would then be created within Membership and use the Free Payment Gateway.

    Also, when I try to view the tabs in my membership options panel they all stay on the General settings information. The tabs change but the information stays the same. But if I type in the address of what the tabs are then the content changes.

    This prompts me to suggest that you uninstall and try a fresh install of Membership. The repair is only for the membership tables created in your database, not the actual plugin.

    Please do not hesitate to let me know if you need anything more! :slight_smile:

    Best,

    Kimberly


    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

  • Macdesign

    Hi Kimberly,

    I thought I read on a thread that you weren't supposed to have the registration allowed. I understand I need to have that on now. But when I do register with it on my membership registration page only shows the Buddypress sign up info. It doesn't have the block to click the "sign up" button. Then when I have completed the process I look from the admin side to see if I'm added to the "basic" membership and I'm not on the list.

    Also, I have tried reinstalling Membership a few times through the upload plugin through wordpress and through my FTP. I was having earlier issues with the signup button not showing up so I followed this thread:

    https://premium.wpmudev.org/forums/topic/membership-unable-to-delete-subscription-plan#post-166139
    about deleting the database tables that start with wp_m and I tried that but then when I went to reinstall it, it didn't recreate the tables and it wouldn't allow me to add any subscription level or access level.

    How do you recommend to reinstall it?

    Thanks for your help,
    Matt

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.