Membership Plugin not assigning proper levels automatically

Hey guys.

I have some subscription plans set up on my site and for whatever reason, when some one signs up for that level it does not automatically assign them to the proper access level. This is probably just an educational piece for me where I am not doing the right thing but any and all help would be greatly appreciated.

Oh and I granted access to my wp-admin via the support feature in the WPMU Dev plugin.

Thanks again guys!

  • aristath
    • Recruit

    Hello there @Ryan, I hope you're well today!

    First of all, there are 6 updates available for your site (including the Membership plugin). Could you please update all your plugins and see if that resolves the issue you're having?
    Second, I see you have both MarketPress and WooCommerce installed on your site.
    These 2 plugins don't work together very well because they are both using a custom post type called "product".

    As for your access levels, why are you saying that the levels are not being applied? Could you please elaborate?

    Please advise,
    Ari.

  • Ryan
    • Site Builder, Child of Zeus

    All plugins have been updated. WooCommerce has been disabled and deleted and I didn't see anything for MarketPress under plugins or settings.

    To elaborate more on the issue: When a new user registers an account with us and signs up under the "seasonal" (http://projectroto.com/register/?action=registeruser&subscription=5) it is not automatically giving them access the the levels of "CFB". So they still do not have any access to what is in the short code [level-cfb] example [/level-cfb]. For instace what is on this page is under the above short code cfb - http://projectroto.com/nfl-cheatsheet-analysis-week-13/ -

    I set up a coupon code for you if you want to attempt to create an account and go through the entire sign up process to replicate the issue. coupon code at check out is "WPMU".

    Thanks for the support Aristath.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Ryan!

    Let's try two things that might be interfering:

    1. Try disabling your caching plugin. Caching is great when you're live, but while you're adding and removing and tweaking plugins and themes, it just gets in the way.

    2. Also try disabling your visual composer. It may not be coded to work with our shortcodes, so it's just stripping them out.

    Let us know if either of these resolves your shortcode issue.

    Thanks, Ryan!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.