Membership Plugin Not Working With Authorize.net

I am experiencing the issue one way and Patrick from support is experiencing it another, but the end result is user never gets asked for payment information after selecting a subscription, entering profile info and clicking sign up.

For me it just refreshes the page and clears the password fields.

For Patrick to gives him a 404 page.

FTY I am using buddypress also. Support access granted. Please help!

  • Vinod Dalvi

    Hi Jesse,

    I hope you are well today.

    I can see you have already asked this question today on your following thread where my colleague @Patrick is helping your to resolve it.

    https://premium.wpmudev.org/forums/topic/the-membership-plugin-is-not-working-properly

    Keep in mind that we try to get to most initial requests within an hour, but depending on the issue additional followup can take longer so don't create multiple topics for the same question to avoid duplication of topics as i am sure you understand this.

    This helps to prevent any confusion (for us) and also this might help other members looking for a similar answer. :slight_smile:

    Thanks,
    Vinod Dalvi

  • Jesse

    Vinod,

    Patrick is the one who told me to post a new topic about it not working with Authorize.net because he was not familiar with the new modifications and wanted someone else in support to help me.

    If you are going to take the time to respond; why not just respond with the answer. My biggest issue with this service is that you give "half" answers that take a day to get. I respond almost immediately and then I have to wait 2 to 3 days to get another "half" response. It would be so much more efficient if we could schedule 5 minutes. I could get all my questions resolved at once!

  • Michael Bissett

    Hey @Jesse, Michael here! :slight_smile:

    First, since we've moved from your other thread (which I've now closed, since as my colleague @Vinod Dalvi mentioned, a discussion across multiple threads can prove confusing, as it was initially), we'll want to recap here:

    The membership plugin will not allow new members to register. You previously told me this was because Authorize.net required an SSL certificate to work. Which (even though I was pretty sure it wasn't the issue) I purchased and setup on the site. However I still have the same issue. The membership plugin will not allow users to join.

    I understand you need SSL to process the credit card. My problem is I never get to that step. I get step 1) choose a subscription. Step 2) fill out your profile information. step 3) Page can not be found. I can't imagine that an SSL certificate would fix that.

    ...I still don't see the subscriptions page when I click register and I still don't ever get prompted to enter payment information.

    Though now, it's appears to be acting like this:

    For me it just refreshes the page and clears the password fields.

    For Patrick to gives him a 404 page.

    After doing some further digging (which, like the other issues, took more than 5 minutes), the cause of this does seem to be related to the SSL certificate. Using Chrome's Developer Tools, I was able to edit the code for the "Subscribe Now" button (see screenshot #1), so that instead of pointing to a https:// link, it instead pointed towards a http:// link. And thus, I was able to load the payment page (see screenshot #2).

    (note: when I used Chrome's Developer Tools to edit the code for the page, it only affected the copy of the page loaded in my browser, it didn't actually make any edits to your site, in case you were curious about that)

    When I tried using the visiting the https:// version of the page however, I got a SSL warning indicating that the certificate belonged to *.websitewelcome.com, which would seem to belong to HostGator, given that it comes up on this page here:

    http://support.hostgator.com/articles/hosting-guide/lets-get-started/dns-name-servers/what-are-private-name-servers

    After allowing an exception, and attempting to proceed with the checkout process, I then came across HostGator's 404 page, which I assume is what my colleague @Patrick ran into here.

    In addition to making sure that the SSL certificate is set up properly (which is something I would want to bring up with HostGator, as they'd be in the best position to resolve that sort of thing), I would also want to make sure to try going through the registration process after clearing the cache in your browser, as well as disabling any browser add-ons.

    I say that last bit, because when I used Google Chrome to register on your site, I haven't experienced a page reload like the one mentioned earlier, so it's possible that there may be something in the browser that's affecting things here. (I tried registering twice, and both times, the WordPress account was successfully created for me)

    Hope this helps! :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.