Membership plugin protected shortcode message is overriding post meta tags

With the membership plugin – activating a protected shortcode replaces all the meta content (author, post date, comments) for a post with the message for the protected content. I use [private] [/private] to encapsulate protected content, I am comfortable as a php developer and am wondering what files I should be looking to modify, I am sure it is something conflicting with my theme.

It is showing up fine with the admin account.

  • DavidM
    • DEV MAN’s Mascot

    Hiya and first off, welcome to WPMU DEV!

    That seems very strange that it would affect meta content. If you remove the shortcode rule or shortcode options in Membership does it still have the same results?

    Could you possibly try inverting the shortcode options in Membership, perhaps setting the shortcode visibility to Yes in Membership > Options?

    Thanks,

    David

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    As we haven’t heard back from you we’re going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn’t resolved, or you have any more questions related to this thread please feel free to post them below and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it’s a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.