Membership plugin still not working!

All of your WPMU plugins are excellent!

Except the Membership plugin!!!

I downloaded the membership plugin 5 months ago. It never worked. After much back and forth thru the forums, levels could still be access without membership.

I have decided now, 5 month later to give it another try.

From the logs, I see that over 145 bug fixes have been done since then!

Yet still it does not work! - same problem.

Spent 5 hours today to try to see it working, but no luck.

I have 3 simple levels setup:
1 free
2 some access
3 all access

All done thru url groups. ie:
site.com/intro
site.com/member
site.com/elite
The URL groups should screen these out, but they do not.

You would think that this was an easy setup, but anyone can access all levels, and some can not access permissible levels.

Is there anyone who can look at the site? I can send screenshots, but this does not demonstrate the problem.

In fact, I can not even set up the membership levels manually, as there is no area under the 'Membership Level' column. It seems to have been removed with the newer updates.

How can I get someone to look at this?

Thanks.

  • Vinod Dalvi

    Hi @Randolf,

    Sorry to hear about the trouble you are having with the Membership plugin.

    Have you added created URL Groups to specific access level by using URL Groups rules?

    What is the access level have you set for the Stranger access level option on the following path?

    Admin area -> Membership -> Options -> General tab

    Could you please share me your site link to troubleshoot it?

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just send info through our contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include any relevant login information (Wordpress admin info username + password )

    Kind Regards,
    Vinod Dalvi

  • Randolf

    Hello,

    I think I found the problem that may have been the issue from the start!

    In the URL Groups, there is a tiny check box at the bottom of the settings, called:
    'Strip query strings from URL'

    Once I checked this, the URL 'Regular Expressions' I am using, suddenly worked fine, and protected areas are now protected!

    This is checked, in addition to the other check box: 'Regular Expression'.

    Such a simple check box, has wasted many hours of testing. I had overlooked this thinking it was for a different purpose.

    Anyways, all is fine now!

    Hope this will help someone else who finds their members protected areas can be accessed from denied levels!

    Thanks again for your quick support!

  • Randolf

    I also wanted to mention this, for anyone else that is having access problems.

    If you use only 'Negative' conditions, and structure all of your access by 'area denial' ONLY (rather than 'area permissive'), then you will find this method a much easier way to perceive access areas in your mind, if logic becomes more complex.

    It will also save you programming 'Positive' areas redundantly, since 'Positive' now becomes the default, and non-accessible areas can be seen by the denial conditions.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.