Membership premium won't upgrade, bunch of errors on back and front

Membership premium won't upgrade, there's a bunch of errors on back and front of the site....

On the back >

Warning: Creating default object from empty value in /home/marketin/public_html/bb-config.php on line 64

Warning: Cannot modify header information - headers already sent by (output started at /home/marketin/public_html/bb-config.php:64) in /home/marketin/public_html/wp-includes/pluggable.php on line 1121

Warning: Cannot modify header information - headers already sent by (output started at /home/marketin/public_html/bb-config.php:64) in /home/marketin/public_html/wp-includes/pluggable.php on line 1121

On the front >

Everytime a user posts an update or forum item it posts but an error message displays above, think it's the same header output message above.

I also can't upgrade the plugin.

Lastly, I want to make a few permanent changes to the files that don't get wiped out, would I make a copy of the file and use the relative file path in a folder within my theme to do that?

Thanks!

  • Jack Kitterhing

    Hi there @bentemple,

    Hope you're well today, did you get the plugin upgraded? I'm showing you are using the latest version here 3.5.1.5.

    Or did you mean your users upgrading their subscription?

    Can you make sure WP_DEBUG is defined to false please in your wp-config.php

    Lastly, I want to make a few permanent changes to the files that don't get wiped out, would I make a copy of the file and use the relative file path in a folder within my theme to do that?

    With the current version there isn't really the possibility for this unfortunately, a plugin can't be overridden like a theme can be.

    In 4.0, which is a complete re-write and we're currently working on it, there will be a large amount of hooks and filters for you to be able to add custom code without it getting overwritten on a update.

    Thank you!

    Kind Regards
    Jack.

  • bentemple

    Hi Jack, yes the plugin has upgraded and understand about the changes.

    I'm still gettng these error messages though and have set wp config to debug false.

    Warning: Creating default object from empty value in /home/marketin/public_html/bb-config.php on line 64

    Warning: Cannot modify header information - headers already sent by (output started at /home/marketin/public_html/bb-config.php:64) in /home/marketin/public_html/wp-includes/option.php on line 747

    Warning: Cannot modify header information - headers already sent by (output started at /home/marketin/public_html/bb-config.php:64) in /home/marketin/public_html/wp-includes/option.php on line 748

  • Jack Kitterhing

    Hi there @bentemple,

    Hope you're well today, I've just download a fresh version of BBpress and in

    BBpress > core > options.php you'll find this code

    /** Legacy ********************************************************************/
    
    /**
     * Checks if there is a previous BuddyPress Forum configuration
     *
     * @since bbPress (r3790)
     * @param $default string Optional. Default empty string
     * @uses get_option() To get the old bb-config.php location
     * @return string The location of the bb-config.php file, if any
     */
    function bbp_get_config_location( $default = '' ) {
    	return apply_filters( 'bbp_get_config_location', get_option( 'bb-config-location', $default ) );
    }

    Which handles the legacy forum component of BuddyPress, for the old bp-config.php do you have that legacy component active?

    Thank you!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.