Membership Pro 2 and Stripe Payment

Can you please investigate why the stripe recurring payment does not work properly? The status is still billed though the card has already been charged? This issue has never been resolved yet from all our websites that's using membership 2 plugin and stripe.

  • Bojan Radonic
    • Head of Support

    Hey Kody,

    Hope you're well today :slight_smile:

    We're currently having a bug related to Stripe and recurring payments which is being worked on by our developers. I see that you've already mentioned this in one of your previous threads so please do not open multiple threads related to the same issue as this just slows down response times from our support.

    We appreciate your patience on this :slight_smile:

    Best regards,
    Bojan

  • Tyler Postle
    • CGO

    Hey Kody,

    Sorry for such a delay on this. Was hoping to have a fix ready for ya when we replied. Our developer is actively working on this. We had a potential fix couple weeks back but turned out there was still some issues with it so it's back on the operating table. Given that it involves the payment gateways it is undergoing a lot of testing to ensure it doesn't cause issues with any working subs.

    We will post back here once we release the fix :slight_smile:

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Kody,

    Thank you for all your patience with this issue, we know it's a critical one. We've been working on a big patch for the last couple months and this particular issue has been extremely tricky. All our potential fixes for it so far haven't passed testing, unfortunately :slight_frown:

    Would you mind sending in your cPanel and wp-admin? The more environments experiencing the issue we can troubleshoot/compare, the better. The reason for cPanel instead of just FTP is so we have access to db tables as well, so phpmyadmin + FTP would work just as well if you don't want to give cPanel access.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -cPanel login url
    -cPanel username
    -cPanel password
    -link back to this thread for reference
    -any other relevant urls

    Look forward to hearing back.

    Cheers,
    Tyler

    • Tyler Postle
      • CGO

      Hey Zeus,

      The issue is that Stripe takes payment but then M2 doesn't reflect that and doesn't re-instate the members membership. So you end up with someone who has paid but didn't receive their membership.

      I do want to make it clear though that this doesn't affect everyone using the Stripe gateway. In-fact, only a small number of sites have reported it compared to how many actually use M2 and Stripe; however, it's a massive issue for those that are experiencing the problem.

      To see if your site gets the issue or not, just watch for when a member is up for renewal and if payment occurs but the membership isn't extended then unfortunately it is happening to your site too.

      Keep in mind that the membership extending process works off of cron so it might not extend the membership immediately after the payment, it could take a couple minutes, but if it takes longer than that, let us know.

      Cheers,
      Tyler

  • timvb
    • Design Lord, Child of Thor

    Tyler Postle I can assure you that there are many users experiencing this issue but in following the etiquette of you support guidelines we don't want to bombard you with similar requests .. .

    I have lost many users through frustration with our membership platform .. it's costing real money and more importantly .. reputations.

    The issue now seems that you are under resourced .. All of us would like to see these plugins and your business be successful .. but at the moment we seem to be on the wrong side of your ongoing billing model .. we keep paying but products aren't working.

    As this plugin is directly related to income and payments for your clients .. I think it deserves a bit more focus and time please.

    I now cringe each time my clients call me because I know they've discovered another glitch in the system.

  • Tyler Postle
    • CGO

    Hey guys, sorry for the late update, the cause of the issue has been found. Ultimately, it's due to the WP cron and it's unreliability. The best option to stop any further subscriptions from being affected is to replace WP cron with a real cron job: https://www.siteground.com/tutorials/wordpress/setup-cron-job.htm

    As for fixing the subscriptions that have been broken - we are still working on a stable solution for that. We've also been working on Membership 3.0, that will rewrite the subscription functionality to fix this issue altogether.

    • Tyler Postle
      • CGO

      Hey Zeus, no ETA on M3 at the moment. I'll see if I can get an update for you guys, I know you've all been waiting very patiently for these fixes. I do know that development on 3 began more recently so it will still have a ways to go at this point from what I understand. Perhaps not the best news, but it is a good start as you mentioned :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.