membership pro pages broken once I installed Forums

Hello,

Membership pro was working fine until I installed Forums. Once I installed Forum then I started getting members pages 2 and up blank... please help.

  • Ash

    Hello @Grace Nasralla

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    What do you mean by membership pages? Do you mean in admin end? Or do you mean the membership pages you selected for registration, accounts etc? Or the pages you restricted by the membership?

    Also, when you see a blank page, would you please enable debug mode and check if any error is shown in that page?

    To enable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', false);

    to

    define('WP_DEBUG', true);

    Please let us know what errors you see there. A screenshot will be very helpful.

    Cheers
    Ash

  • Grace Nasralla

    Hello, and thank you for your help.

    I did as per your instructions, it gave me

    Notice: Use of undefined constant BP_COVER_PICS_SLUG - assumed 'BP_COVER_PICS_SLUG' in /home/osbn/public_html/pages/wp-content/plugins/bp-cover/bp-cover.php on line 29

    Which is not related neither to membership pro nor to Forums.... so I fixed that and now its not showing :slight_smile:

    But the issue is still there. When I go to membership pages at the front end I can view all the members in the MEMBERS page, but only for page one.... once I click on page 2, 3, .... then the pages turn into blank!!

    When I uninstall Forums, all goes back to normal and then I can view all Members Page ( problem is only at the front end.)

  • Grace Nasralla

    Today I tried installing buddy pics plugin and again at the front end page 2,3,.... gave me blank pages... I could only view the members page 1. I would really appreciate some help as I would like to use both Forums and buddypics plugins

    Now I noticed that in the Plugins folder there is another folder called __MACOSX, and I am not sure if that should be there?? public_html/pages/wp-content/plugins/__MACOSX

    I am enclosing an image of what is in the __MACOSX folder... maybe it doesn't have anything to do with it, but it caught my attention and I thought I'll send it.

  • Ash

    Hello @Grace Nasralla

    I hope you are well today.

    I am sorry for the delay.

    Membership Pro plugin doesn't have any members page, I think this page comes from your BuddyPress plugin.

    Now I will recommend you to run a plugin conflict test. Please deactivate all plugins except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let me know what you get.

    About the _MACOSX folder, that's a file system folder comes from MAC operating system. I think when you uploaded the plugin (or who did it), the uploaded from a MAC machine and didn't delete that folder before uploading. There should not be anything harmful though. But it's always safe to delete folders like these (.svn, .git etc)

    Cheers
    Ash

    P.S.: One important thing, would you please go to Settings > Permalinks and make sure you have selected Post Name? If yes, please save again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.