Membership: protected downloads doesn't completely obscure URL

Hi - I'm running Membership Version 3.0.1

In the Membership Options for Download / Media Options my settings are:
Your uploads location : http://mydomain.com/wp-content/uploads
Masked download URL : http://mydomain.com/downloads

In my general media settings I have selected this option to further obscure my media URLs:
"Organize my uploads into month- and year-based folders"

however my download URLs display like this:
http://mydomain.com/downloads/2012/02/mydocument.pdf

when I expected them to display like this:
http://mydomain.com/downloads/mydocument.pdf

Is this expected behavior? I thought the point of this feature was to obscure the true URL with the "Masked download URL"...

thanks