Membership: protected downloads not working

I'm using Membership 3 RC 2 with Buddypress

settings:
Your uploads location: wp-content/uploads
Masked download URL: downloads
Protected groups: Protected Downloads

I've added "Protected Downloads" as a rule in the appropriate Access Level

In a blog post I've uploaded a PDF and protected it with the group "Protected Downloads"

I insert it into my post with the full URL:
http://mywebsite.com/wp-content/uploads/my-file.pdf

to the user it appears masked:
http://mywebsite.com/downloads/my-file.pdf

but when the link is clicked on the user sees a "No Access" graphic

please advise

  • locomo
    • The Incredible Code Injector

    yup - that's it :slight_smile:

    sorry if i wasn't being clear - tried to get all of my settings and setup into my initial post to minimize a lot of back and forth

    but yes, everything works - the URL to the PDF is successfully masked by the plugin but the user sees the "No Access" graphic when they click on it

  • locomo
    • The Incredible Code Injector

    i've found a solution that works now and i'm wondering if i've either found a bug or don't understand something correctly

    i was using negative rules to manage this download .. i have 3 download groups and i used a negative rule for my access level and checked off the 2 download groups i didn't want my user to have access to

    when i changed this to use a positive rule and only checked of the 1 download group i wanted my user to have access to it worked

    this is fine and all.. but my understanding is that a negative rule should have worked just as well here .. can you please let me know if i'm not understanding negative rules correctly or if in fact this might be a bug?

    cheers!

  • aecnu
    • WP Unicorn

    Greetings locomo,

    I am truly sorry for the delay in a response as it appears this ticket got away from me in the ticket system.

    It is very possible it was a bug at the time and possibly addressed in the most recent version of the Membership plugin version 3.0.1 in which there were many bugs fixes.

    Please advise concerning this issue and if it is indeed resolved.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings locomo,

    Then from my understanding the positive rules are indeed working, that is great news.

    would love to know why negative rules weren't working .. i.e. is it a bug in membership or i'm i not understanding something correctly?

    For this question I will see if I can get the lead developer in here to answer.

    Personally I know I am a bit different with my thinking of if it is not broken do not fix it and go with what I know works. Maybe that is the old school in me .... lol

    However, I am not the one asking the question. Therefore though it may take a bit longer then a normal ticket, I will try to get the lead developer in here with his invaluable insight to answer your question asap.

    Cheers, Joe

  • locomo
    • The Incredible Code Injector

    hey thanks for the response - i'm a little confused by what you mean if it is not broken do not fix it - because to me it definitely seems like its broken

    positive rules have always worked and it is a workaround, but i have a use case that would be much easier with negative rules working:

    I have a "Premium" level. This level should have access to all Protected Groups except one called "Super Premium". We plan to add a number of different Protected Groups going forward. It will be much easier to maintain this level by setting a negative rule for the "Super Premium" Protected Group. That way whenever we add a new Protected Group the "Premium" level will inherit access to these new groups rather than us having to explicitly add access with a positive rule

    thanks for you help!

  • aecnu
    • WP Unicorn

    Greetings locomo,

    Thank you so much for the clarification, it is certainly appreciated.

    I have indeed asked the lead developer to come in here with his invaluable insight seeking his advice/advise us on what we may be missing here or if this is indeed the expected procedure.

    I do see your clarified point and it would seem logical whenever we add a new Protected Group the "Premium" level will inherit access to these new groups rather than us having to explicitly add access with a positive rule

    On a side note, have you by any chance upgraded to version 3.0.2?

    It is certain that the developer will want to know is why I ask.

    Thanks again for your patient input.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings locomo,

    Thank you for your demonstrated extreme patience concerning this issue, it is greatly appreciated.

    Though I have notified the developer of this standing ticket awaiting his invaluable insight, I see that he has yet to make an appearance offering any advice that he may have to resolving this issue if any.

    I shall notify him again.

    Sincerely, Joe

  • Kimberly
    • Champion of Loops

    @locomo,

    I believe that the developer is on the cusp of releasing another update for Membership. Thanks for your AMAZING patience here! Fingers crossed it will help you finally get this resolved!

    Just to clarify, you are using the positive rules as a workaround right now for the Membership Download Protection as the download access value doesn't work when used as a negative rule?

    Just want to summarize this rather long ticket incase I need to mail the dev directly.

    Best,

    Kimberly

  • aecnu
    • WP Unicorn

    Greetings locomo,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • Rik
    • Flash Drive

    Hi,

    I am setting up a site with the Membership plugin, and I am having the exact same problem, except that it is happening with positive rules.

    Latest versions of everything,

    Hopefully we can add a solution to the end of this thread?

    Thank you,

    Rik

  • aecnu
    • WP Unicorn

    Greetings Rik,

    Thank you for your understanding and for letting us know that you have/will create a new ticket in regards to your issue for us to work with - it is greatly appreciated.

    Have a GREAT weekend and thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.