membership registration simply not working for me at all

Hi, I have the Membership plugin installed and I'm sort of following this tutorial I came across to set up a membership subscription where paid users degrade to "free users" after X amount of time. I think I have everything set up correctly, but now that I'm trying to see if it all works, I can't even get a registration to work.

On the registration page I created, I see the default unstyled subscribe form that is output by [subscriptionform], but when I enter data and submit, here is what happens:

I *briefly* see it flash to a page that looks like it has a UI to select a subscription type or something, but then the browser refreshes to the membership page again, only with everything unstyled, and the line "Nothing found. Oh, Sorry, no posts matched your criteria" in place of where the next step of the sign-up UI should be.

On the backend, I receive an email with credentials to log in (including a new password, even though I just selected one in the subscriptionform UI ???). If I try to login, the message returned is that the user is not active.

Can anyone help me out with what might be happening here? It sure seems REALLY broken to me, and I don't even know where to start. I just assumed that the plugin would smoothly run a registration if you used the appropriate short codes in the right places...

Thanks!!!

-sp

  • msmith29063
    • New Recruit

    Yeah, was just looking at that, since you suggested other plugins might be of concern. Unfortunately, I have no idea about most of these plugins, as I inherited this site and am just trying to beat into slightly better shape (or pass it off to a Wordpress developer).

    But I disabled that one and the behavior is still the same.

  • msmith29063
    • New Recruit

    So I've deactivated Register Plus and Roll Manager, and I still get this issue where the default Membership registration flow jumps out to this secure URL. I'm not a Wordpress developer, but I'm wondering if there is some scripting built into some template or global javascript library that might be somehow conflicting with the Membership code. Does the module use javascript to function, or is at a straight client-server conversation through application flows? Could you suggest any place I could look to see what might be causing this bail-out to a secure url in the middle of the Membership flow? Where are the possible points of vulnerability in the Membership module where an outside influence could jack it up?

    Many thanks for your help. If I find out this whole site has been tweaked for the bad design that we're trying to overcome using WPMUdev plugins, we may have to bail on the site and start from scratch building a site around the Membership plugin. But man, I don't want to have to suggest that...

  • Barry
    • DEV MAN’s Mascot

    Was waiting for you to come back with your findings?

    There are a bunch of Javascripts that don't load due to the https refresh however. The browser complains of a bad certificate and will not load the resources. Going to try to see if there's a way to work around that.

    The membership plugin doesn't do a refresh, so it has to be theme or plugin related. What do you have set up to control your SSL certificate and control which pages use it or don't use it.

  • Mason
    • DEV MAN’s Sidekick

    Hiya msmith29063,

    Anything further here? As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.