Membership Rules & Access Levels are not working

Please review my live chat -

Dylan Elmgreenat 2:30 pm
I am having issues with membership settings. I have Visitor setting and the rules are that a visitor can access every page and the menu.
Now it doesnt matter if I have the positive rules set or I have no rules set whatsoever a stranger will not have access to anything.
http://www.revolutionarymindfulness.com

Paul
Paulat 2:30 pm
@Dylan Elmgreen ok

Paul
Paulat 2:31 pm
@Dylan Elmgreen But obviously this is not working as I can see the menus.

Dylan Elmgreen
Dylan Elmgreenat 2:31 pm
I need them to have access

Dylan Elmgreen
Dylan Elmgreenat 2:32 pm
try clicking on them especially the store / events

Dylan Elmgreen
Dylan Elmgreenat 2:32 pm
Even if I take away any rule access is denied.
If I create full access through positive rules on the stranger/visitor access is still denied to an unlogged in user

Paul
Paulat 2:33 pm
@Dylan Elmgreen just a sec. Let me get into my own dev site.

Paul
Paulat 2:33 pm
@Dylan Elmgreen Multisite or regular?

Dylan Elmgreen
Dylan Elmgreenat 2:33 pm
regular

Paul
Paulat 2:35 pm
@Dylan Elmgreen So Membership > Access levels you have the Visitor entry? and it doesn't have any or - rules? Correct?

Dylan Elmgreen
Dylan Elmgreenat 2:35 pm
Currently it has full access through positive rules settings. There are no existing negative rules for a stranger/visitor

Paul
Paulat 2:36 pm
@Dylan Elmgreen And on Options then the General tab.

Dylan Elmgreen
Dylan Elmgreenat 2:36 pm
I have a Visitor access level

Dylan Elmgreen
Dylan Elmgreenat 2:36 pm
?

Paul
Paulat 2:36 pm
The first option for 'Stranger settings' is set to what level?

Dylan Elmgreen
Dylan Elmgreenat 2:36 pm
Visitor

Paul
Paulat 2:37 pm
@Dylan Elmgreen hmm. strange. I can reproduce your issue on my site if I change that stranger dropdown to something else.

Dylan Elmgreen
Dylan Elmgreenat 2:37 pm
ok

Dylan Elmgreen
Dylan Elmgreenat 2:37 pm
not sure

Paul
Paulat 2:38 pm
@Dylan Elmgreen So just going through your settings. Do you have anything at all defined under Membership > URL Groups?

Dylan Elmgreen
Dylan Elmgreenat 2:39 pm
It is still in the sidebar, nothing set

Paul
Paulat 2:39 pm
@Dylan Elmgreen Then I'm not sure. Going to have to refer you to the community forums as well. Sorry.

Dylan Elmgreen
Dylan Elmgreenat 2:40 pm
bummer, ok. Thanks for trying... I will try to update all my plugins. It happened out of nowhere which is what is weird. Thank you

Paul
Paulat 2:41 pm
@Dylan Elmgreen What other plugins are you running. There might be some issue with plugin collisions. Maybe try disabling all other plugins. Though this does sound like a configuration issue.

Paul
Paulat 2:43 pm
@Dylan Elmgreen I need to close out chat. Thanks.