Membership Shortcodes and Addons not working

Hi,

The current Version 1.0.3.1 of Membership Pro plugin has the following errors after update.

1. Form Shortcodes

This Registration form: [ms-membership-register-user membership_id="632"] shortcode can only display in public. For a registered member, the page is blank.

This Subscribe Button: [ms-membership-buy id="632"] shortcode works both public and member's area.

2. Login/Logout Redirect Shortcode

[ms-membership-login redirect_login="Redirect URL"]

How to set the redirect to the current page. Example, the reader is reading Economy page. Then, he clicks Register or Login. After that, he is taken to the Economy page.

3. Coupon Addon

Enabled, but when refresh, it becomes disabled i.e. can not be enabled.

4. Profile Field Addon

the Display As is not working. I can not select the name to display. Just blank drop-down field.

5. Restored Data

Because of the above problems, I deactivated the plugin and deleted through CPanel, then reinstalled it through normal wordpress plugin page. All the membership data was automatically restored and was not deleted. Why? How can I have the brandnew plugin with no data?

Regards,

Vi

  • Rupok

    Hi Vi, hope you had a wonderful day.

    This Registration form: [ms-membership-register-user membership_id="632"] shortcode can only display in public. For a registered member, the page is blank. This Subscribe Button: [ms-membership-buy id="632"] shortcode works both public and member's area.

    Well, it's logical. When a user is already logged in, he doesn't need to register his account again. So logged in users don't see that registration form. But suppose a user is logged in, and he is subscribed to Membership ID 1, now he may want to subscribe to Membership ID 2. So subscription signup link is shown.

    How to set the redirect to the current page

    If your current page is Protected with Membership 2 Pro, then it will automatically redirect to that page after login. But in your scenario, where user clicks to login from any random page, I'm afraid, this is not possible out of the box. You can redirect them to any pre-defined URL but not dynamically redirect to his current page.

    Coupon addon is working fine on my test site, so this is your site specific issue. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    "Display As" dropdowns are also working on my test site. Please check the attached screenshot for reference.

    Our plugin developer can give best idea regarding how you can delete all Membership 2 Pro data. I've pinged him and I believe, he will come up with a suggestion very soon. I'll update you as soon as I get something from him.

    Have a nice day. Cheers!
    Rupok

  • Victor Rak

    Hi Rupok

    Many thanks for your prompt reply.

    1. Form Shortcode:

    That's not still logical. Why? Because when I use This Subscribe Button: [ms-membership-buy id="632"] shortcode, it brings to the same form as [ms-membership-register-user membership_id="632"] although the user is logged in.

    2. How to set the redirect to the current page:

    The pages are Membership Pro's. Maybe because of the problem in question #1. When a visitor is reading the Economy membership subscription, he clicks register or login.

    3. Coupon addon:

    No, it's a problem with the update version. Switch back to old version, it works.
    Same thread: https://premium.wpmudev.org/forums/topic/membership-2-pro-coupons-wont-turn-on

    4. "Display As" Profile field addon:

    It works fine in the addon setting area. But it does not work in the output page or registration page.

    5. Old data: &reset=1

    That's helpful.

    Have a nice day.

    Vi

  • Nithin

    Hi Victor Rak,

    Hope you are doing good today. :slight_smile:

    [ 4. Profile Field Addon: the Display As is not working. I can not select the name to display. Just blank drop-down field.
    ** It works fine in the addon setting area. But it does not work in the output page or registration page.]

    Thanks for pointing that out, I'm able to replicate this, and can confirm this as a bug. The Display As doesn't provide any dropdown option. I have reported this to the developers, and will keep you updated once a patch has been made available.

    Thank you for reporting. Please let us know if you still need any further help. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.