Membership showing 404 instead of Protected Page

I know others have had this problem before over the last couple of years but I’m wondering if it’s been fixed.

I’ve got a page set up as protected from visitors but the link leads to a 404 message and not the “protected content” page. Protected posts are working fine, just this page isn’t working.

Any suggestions about a fix?

Thanks.

  • Jack Kitterhing
    • Code Norris

    Hi there @cameron,

    Hope you’re well today and thanks for your question! :slight_smile:

    This was fixed a while back and shouldn’t be happening in the latest release, can you post a link please to one of the pages in question.

    Also could you grant support access please via your wp-admin > WPMU DEV > support > support access and click “Grant Access”.

    Thanks!

    Kind Regards

    Jack.

  • Cameron
    • Site Builder, Child of Zeus

    Hey Jack. Thanks for the reply. Support access is on.

    The page in question is:

    http://napoleonbonapartepodcast.com/premium-podcasts-3/

    Should only be visible to members.

    BTW, while I have your attention, I just discovered another problem.

    I’ve got the SB Welcome Email plugin installed to send welcome emails to new members. But I just noticed in testing that it sends the login details to members BEFORE the paypal transaction is completed, so if people cancel out of the transaction, they can still login as a member. Any ideas on that one while you’re at it?

    Cheers

    Cameron

  • Jack Kitterhing
    • Code Norris

    Hi there Cameron,

    Thanks for the additional information, I’ve just checked this and it should be working now.

    The issue was the protected content page wasn’t set in membership > options > membership pages, I’ve re-created the page and set that, it now correctly displays the protected content message. :slight_smile:

    On the welcome emails, they would receive their login details before completing payment as it registers the user so it has someone to assign the subscription to, as we use the unique user ID WordPress assigns the member.

    I noticed you had set a default membership in membership > options, if you set that to none and just leave the visitor access on the top option, unless they pay, they’d effectively only have the visitor membership.

    Thank you!

    Kind Regards

    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.