Membership "Stranger" level not working

I had started with Membership Lite, and successfully configured a "visitor" access level for strangers to allow unauthenticated users to see (most of) the site. After upgrading to the paid version of Membership this isn't working - "strangers" are able to see the pages in the menu, but not any page content. On the home page I am also getting this error:

Warning: Cannot modify header information - headers already sent by (output started at /home/benfineman/kindredcam.com/wp-content/themes/SimplePress/epanel/custom_functions.php:374) in /home/benfineman/kindredcam.com/wp-includes/pluggable.php on line 881

I have disabled all other plugins. And confirmed that the "visitors" level is active. What can I do next?

Thanks
Ben

  • Timothy Bowers
    • Chief Pigeon

    Warning: Cannot modify header information - headers already sent by (output started at /home/benfineman/kindredcam.com/wp-content/themes/SimplePress/epanel/custom_functions.php:374) in /home/benfineman/kindredcam.com/wp-includes/pluggable.php on line 881

    This error refers to your SimplePress theme:

    /SimplePress/epanel/custom_functions.php

    Often it occurs with some extra whitespacing be the <?PHP tags.

    You might like to try updating your theme or re-uploading if it is the current version.

    For the other issue with stranger level can I please see screenshots of the Level setup and your plugin settings including where you set the stranger level in Options.

    Thanks.

  • bfineman
    • Site Builder, Child of Zeus

    Thanks for the quick response! Please find sceenshots following. I enabled all the pages for "visitor" for troubleshooting ("stranger" still has no content access, but can view the home page without any content).

    I'll try reloading the theme as it is on the current version.

  • bfineman
    • Site Builder, Child of Zeus

    Reloading the theme did not remove the headers error for "stranger", but the headers error does not appear when I'm logged in as admin, so I'm willing to ignore that for now until we get the permissions issues resolved.

  • bfineman
    • Site Builder, Child of Zeus

    A couple more screen shots so you can see exactly what I'm talking about. The behaviour is a little weird - even if "stranger" had no access I would expect disallowed pages to not appear in the menu. Instead they appear in the menu but redirect to the "no access" page when you try to hit them (and don't show up in the theme slider, etc)

    Edit: only the "not logged in", working incorrectly screen shot uploaded here.

  • Timothy Bowers
    • Chief Pigeon

    A couple more screen shots so you can see exactly what I'm talking about. The behaviour is a little weird - even if "stranger" had no access I would expect disallowed pages to not appear in the menu. Instead they appear in the menu but redirect to the "no access" page when you try to hit them (and don't show up in the theme slider, etc)

    That's how Elegant Themes work.

    They just pull in the pages. You can go to:

    Admin --> Appearances --> Menus

    To define a custom menu there.

    Can you please also go to:

    Admin --> Settings --> Permalinks

    And change that to a custom one, just don't leave it as a the default one.

    Let me know how that goes.

    Take care.

  • bfineman
    • Site Builder, Child of Zeus

    Thanks, however, perhaps me mentioning the menu was a bit confusing. The main issue is still that the "visitor" access level, which is assigned to "strangers", should have access to all the pages (that is the way I set it for testing), but instead has access to none.

    Thanks,
    Ben

  • bfineman
    • Site Builder, Child of Zeus

    Can you please also go to:

    Admin --> Settings --> Permalinks

    And change that to a custom one, just don't leave it as a the default one.

    I'm guessing this is a best practice thing (I am a Wordpress newbie), can you say more about what a better permalink would be?

  • Timothy Bowers
    • Chief Pigeon

    I'm guessing this is a best practice thing (I am a Wordpress newbie), can you say more about what a better permalink would be?

    It's really your choice. But anything other than default.

    If you want the category in the url for an extra keyword? Or you want the date then enter that?

    I like the date in some of my URLs, but it's not always practical depending on the type of site and content you have.

    Anyway, let me know how that goes after you've done that. :slight_smile:

    Take care.

  • bfineman
    • Site Builder, Child of Zeus

    Ok! I have changed the permalinks. The URLs are much more asthetically pleasing, thanks. But, the "strangers" permissions problem remains. What next?

    Is there a way I can delete the Membership plugin and start from scratch? I'm worried that something went wrong when I upgraded from Membership Lite to Membership "paid" - data from "Lite" was still present in the new version so I know I didn't start fresh.

    Thanks,
    Ben

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    The Lite version is a real old version of the current pro.... I suppose there could be some issues there.

    I think before going that far if it's ok with you I'd like to take a quick look?

    If that's good then please send in:

    - Mark to my attention
    - Link back to this thread
    - Admin access (including Membership admin access)
    - FTP
    - cPanel (for use of PHPMyAdmin)

    https://premium.wpmudev.org/contact/

    Take care.

  • bfineman
    • Site Builder, Child of Zeus

    Hi Tim,

    As I mentioned in email - we are getting closer! "Stranger" access level now sees page content as expected, with one exception - the featured images that are pulled for the front page slider are not displayed at "stranger" level (so the front page layout appears all messed up). When authenticated as admin, the featured images are displayed just fine.

    Thanks,
    Ben

  • bfineman
    • Site Builder, Child of Zeus

    Cole got in touch with me and make some changes to my Elegant Themes code, and things seem to be working! Thanks alot guys!

    Now, maybe back to easier questions. I don't know if I am doing "login/logout" in the recommended way for Membership. Right now I have the stock login page from my theme (under Membership -> Log In) but after login it goes to the Wordpress profile page - can I make it go to a different page (probably the "Schedule Now" page)?

    Also, how should I handle "log out"?

    Thanks,
    Ben

  • bfineman
    • Site Builder, Child of Zeus

    Tim sent me the link fors two plugin for url redirects on login and logout, works like a charm. Thanks again Tim and Cole! I have upgraded to a full membership based on this experience. Next, on to the Appointments+ plugin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.