Membership: Won't show widgets in IE but will in Firefox / Shows short codes when logged in.

OK so it's kind of two different things but both pertain to the installation of the Membership Plugin.
1. When viewing the site with Internet Explorer, on the home page my widgets disappear. They were OK prior to the installation. Any ideas? Is it something to do with some permission level? And if so why doesn't it do it in Firefox. Again both worked fine prior to installation of Membership.
http://agentattractor.com/

Second issue. when I'm logged in (admin of course) and I preview the page with the [free] shortcode, it shows up. I can see it in the post. When I view the post not as a member it displays properly. I am not sure what's happening.
http://agentattractor.com/lead-generation/analyze-your-real-estate-farm-area/

  • Philip John

    Hiya,

    Apologies for the delay in getting to your issue!

    1. This definitely sounds like a theme issue, especially looking at Tim's screenshot. You should enable the default theme and see if you get the same issue there. If not, you need to look at modifying your theme as it doesn't seem to work well in all browsers.

    2. Can you post as much detail as possible (screenshots would help) of your setup including levels, subscriptions and the rules therein please? Also check that the appropriate levels and subscriptions are enabled and that you've correctly added the shortcodes.

    Cheers!
    Phil

  • Barry

    Any ideas? Is it something to do with some permission level? And if so why doesn't it do it in Firefox. Again both worked fine prior to installation of Membership.

    Protection is handled server side, so any browser issues won't be because of protection, as the guys say - check your theme and try testing with different ones to compare.

    Second issue. when I'm logged in (admin of course) and I preview the page with the [free] shortcode, it shows up. I can see it in the post. When I view the post not as a member it displays properly. I am not sure what's happening.

    That'll be because the plugin isn't running any rules on the front end when you are logged in as the admin user. You need to test with other, non-membership admin users.

  • Mason

    Hiya BanditSiix

    As we haven't heard back from you we're going to assume the problem
    was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this
    thread please feel free to post them below and tick the 'Mark as Not
    Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU
    DEV, it's a pleasure to help you out and we look forward to being of
    assistance in the future.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.