Membership2 pro plugin stops menu to work

Membership2 pro plugin stops menu to work, If a page has membership access enabled and if a user with/without page access login and check that page menu is not working in mobile, the menu is working as it is if the page doesn't have membership protection enabled

http://smartminds.io/staging this page has MU plugin content protection enabled and Menu is not working.
In this page content protection is disabled so menu is working
http://smartminds.io/staging/about-us/ please help me solve this issue asap.

The Grant access is given by my client https://premium.wpmudev.org/profile/speak/

  • Predrag Dubajic
    • Support

    Hey Dinakar,

    Hope you're doing well today :slight_smile:

    I must say that I don't quite understand this issue, I checked both of the linked pages with Chrome responsive mode and on my android phone, each test opened the protected page and the menu was showing and working.

    Could you provide us some additional info about this, perhaps steps I could follow or attach some screenshots for better understanding?

    Best regards,
    Predrag

  • Dinakar
    • WPMU DEV Initiate

    Hi Predrag,

    Thanks for quick response, this problem is when user logged in sorry for all the confusion here, please access the website with provided grant access and check this issue by logging in, for loggedin users the menu is not working on the pages where MU plugin is enabled. Check teh screenshots for Home and About us pages.

    Thanks.

  • Predrag Dubajic
    • Support

    Hi Dinakar,

    Thanks for the additional info, I did some further tests and noticed that the issue is there even without the M2 active.

    The issue seems to be coming from WP Rocket minification, when that's disabled the menu works fine.

    Since you have Hummingbird installed as well can you try disabling minification inside WP Rocket and activate it in HB as HB offers you to exclude files from minification.
    Try disabling minification for files one by one to see which one is causing the issue and then leave that file unminified and enable it to the rest of them.

    Best regards,
    Predrag

  • Dinakar
    • WPMU DEV Initiate

    Predrag Dubajic Wp-rocket debug solved the issue but when I activated Hummingbird all my font awesome icons are gone, if there any other option instead of disabling minification of font awesome by hummingbird? Currently I deactivated the HB plugin you can access my backend and can make necessary changes.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.