Memberships 2 Pro causing too many redirects (BuddyPress Active)

Logged out, visiting my site as an unregistered user--
When Memberships tries to redirect me to any Membership specific page (Protected Content, Login etc) it times out and returns with the following

Chrome:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@gunzgallery.com to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Additionally, a 302 Found error was encountered while trying to use an ErrorDocument to handle the request.

Safari:

Firefox:

I have deactivated Memberships & reactivated, but the same result occurred. When logged in, the dashboard works as normal, and all pages function as they should.

Sidenote: I was not revising any code in the backend when this began occurring, other than the child theme style.css. Also, I have not revised any files within the Memberships plugin itself.

  • Adam Czajczyk

    Hello Ashley!

    I hope you're well today and thank you for your question! I'd like to take a closer look at your setup so I tried to access your site using a support access that you granted. Unfortunately, I wasn't able to. Furthermore, the front-page of your site is not loading for me either. I also asked my colleagues (from another parts of the world) to visit it but it didn't load for them to.

    The error we're all getting on a front page says "[an error occurred while process this directive]". That's a server side error. Please make sure that your site is up and running and let me know here. You may need to get in touch with your hosting provider to fix this.

    Once the site is available, I'll investigate the Membership 2 Pro issue and hopefully be able to help you with this in no time.

    Best regards,
    Adam