Memberships New vs Paid, why are some customers not charged

Hello,

I have noticed that some of the people purchasing memberships have an invoice saying "new" but have not moved onto "paid" how is this possible? It looks like they have access to everything that the membership gives access to but they payment has not gone through?

I am not sure I understand what is sign on.

thanks,

Dre

  • Patrick
    • Support Monkey

    Hi there @Dre

    Welcome to WPMU DEV, glad to have you aboard!

    If you are referring to users who have joined your memberships very recently, that is actually by design as some payment processors can take several minutes to transfer the required data to the plugin.

    So the questions are:

    - which payment processor are you using in the plugin?
    - are these very recent new users, or have they been members for a longer period?

  • Ash
    • WordPress Hacker

    Hello @Dre

    I hope you are well today.

    I have just tested in your site. I am attaching two screenshots, 1 is before payment and 2 is after payment. You will see that, before payment, I was not assigned any membership. But after payment I was assigned to correct membership.

    Would you please try yourself again and let me know?

    Cheers
    Ash

    • Dre
      • The Incredible Code Injector

      Hello Ash, I know it works...some people signed up fine...that is not the issue.

      my issue is that I have only 85 transactions in Stripe and 140 supposedly paid members. If I click on some of them it says payment $0.00 .

      Up until today they could browse the website even though they had not paid, I think that got fixed today after the update. But I still have people that I am not sure if they paid or not.

      Would it be possible to have a Skype call about this, i feel like things are getting lost in translation.

      thanks

  • Ash
    • WordPress Hacker

    Hello @Dre

    I hope you are well today.

    I have just talked to the developer and he said, there was a issue but the issue was fixed in latest update. I can see you have updated the plugin. Do you have any problem after updating the plugin?

    If no, then you have to manually revoke membership from old users (that you were having problem with) and let them re-subscribe again.

    Please let us know.

    Cheers
    Ash

    • Dre
      • The Incredible Code Injector

      The issue is still occurring, I see two new users since yesterday,

      one that hasn't paid but has the membership

      one that has paid and has membership

      Also I am not sure I understand what the issue is, did they (the people that got a freebie) enter payment details but the transaction didn't go through? or did they somehow just get a free ride?

      I really need to speak to the developer, can you please arrange a skype call

  • Ash
    • WordPress Hacker

    Hello @Dre

    I hope you are well today.

    Skype call is not possible, I am afraid. But I am including a developer @Jack Kitterhing for his valuable opinion on this issue. He might be away in the weekend, but he will reply as soon he is online.

    Cheers
    Ash

  • Jack Kitterhing
    • Code Norris

    Hi there @Dre,

    Hope you're well today!

    Could you send through the following please so I can take a closer look at this for you?

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include cPanel/Phpmyadmin details (for database).
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Dre,

    Hope you're well today, thanks for sending through the info, I've been testing and debugging this both on your install and mine.

    Below I've pasted the issues you where having with my replies under each one.

    - some people are being assigned a membership even though they haven't paid, since the latest update this membership is expired but it still counts them as having it so I have to manually click on each member to check if they have paid or not

    I've tested this on your install and mine and was unable to replicate, can you give me the names of accounts or time stamps of when this happened, I can then check the database for any possible issues.

    - Buddypress add-on blocks non-admins from adding friends or creating groups regardless of which rules I set

    I've tested and replicated this, this will be patched in the next release.

    - Login system displayed on protected pages does not show social media login system

    There's currently no direct integration with any social login features, if the social login plugin you're using uses shortcodes, you could place those shortcodes on the registration page generated by Protected content in wp-admin > pages > register > edit.

    - Default memberships (activated today) is not assignable to members

    After testing this is because of the social login which appears to be the only way to get a non-premium membership, myself and the lead developer are looking into this and this will also be patched in the next release.

    Thank you!

    Kind Regards
    Jack.

  • Dre
    • The Incredible Code Injector

    Thanks for the info @Jack Kitterhing

    chinny1912 is an example user that has an expired FoundingMembership that got assigned even though he didn't complete payment. I think it is happening when someone clicks on the Pay system but then does not go through with it.

    Is there a way to edit the wording on the final payment stage that explains what the payment recurrence is? Right now it says "$99 each 3 months" users are misunderstanding it to mean $99 every month, I need to change it to "$99 every 3 months" or something similar

  • Dre
    • The Incredible Code Injector

    One user that got a completely free membership (not expired) without paying was vladimir-sabev I manually removed his membership

    UPDATE: I got in touch with vladimir and he has now gone through the correct payment

  • Patrick
    • Support Monkey

    Hey there @Dre

    I hope you're well today!

    Thanks for updating us here with the faulty usernames. I'll be sure @Jack Kitterhing is alerted.

    As for changing the text in the payment process, the preferred way is to create a custom language file for the plugin wherein you can modify any translatable text-string to suit your needs.

    To do so, open protected-content-en_EN.po in a program like PoEdit, and make the desired change to the text-string(s) you need (screenshot below). When you click Save in PoEdit, it will automatically save & create the .mo file with the same text-domain (& language you set when you opened the .po file) appended: protected-content-en_EN.mo

    Then upload the .mo file to your wp-content/languages/plugins folder. For more details, see the Using Translations section on this page:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/translations/

    I hope this helps! And thanks for being a member :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.