Memory Limit Setting: Unable to update the 'memory_limit'

I am completely new to this. I was configuring the settings like this help file told me to:
Snapshot Pro Instructions

And when I got to the "Memory Limit" section there is no field for changing the value. Instead, I get this error:
Warning: Unable to update the 'memory_limit' via the PHP function init_set. This means in order in to increased the allowed memory limit for Snapshot you will need to make the change directly in your php.ini file. Contact your host provider for details.

My memory in wp-config is at 96M and the settings for the default constants file in the wp-includes is 40 for single and 64 for multi site.

I also have my php.ini located in the folder above public_html with the memory limit set to
64M.

What am I doing wrong here? I have full access to all the files, the cpanel and the whm, why can't I see the input field for the memory limit option in the SnapShot Pro plugin Settings page? Is it necessary that I have this set here?