Menu on scroll disappeared from my site

Assuming this is related to Hummingbird, but I also ran smush and I enabled Hustle Pro, but did not enable a top alert. Anyway, before I installed, I had a menu that would appear at the top of my site when I scrolled down. It is no longer appearing when I scroll on the site.

  • Nahid

    Hey Brad !
    Hope you are doing well today!

    I tried to access your site but I don't believe the Staff Access is working as it may be restricted by any security plugin. You can send the credentials privately through our contact form:

    Send in:

    Subject: "Attn: Nahid Mohit"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    More suggestions : So according to your testing, Hummingbird isn't causing the issue as it was still not working while Hummingbird was disabled. Could you initiating a plugin conflict test? You can do that by following the process here.


  • Nahid

    Hey Brad !
    Hope you are doing well today!

    I just checked in your site, disabled minification inside Hummingbird and it seems the menu worked then. So definitely a conflict with Minification. As the warning while Minification says:

    Note: Moving files between the header and footer of your page can break your website. We recommend tweaking and checking each file as you go and if a setting causes errors then revert the setting here.

    I've done a few tests on your site, even when the minification is disabled on all of your JS & CSS files, the site seems loads incorrectly. After excluding all files from minification the file list wasn't visible, most likely this because of the conflict with a plugin. Please check for a conflict with a plugin as it shows at this flowchart.

    The Minification indeed can break themes, because not all of them are built with WordPress standards.

    Here's what you could do:

    1. Go to "Hummingbird -> Minification" page and use "Check files" button
    2. One the process completes a list of files will appear; most likely the site will break again too
    3. Then follow this picture:

    What will happen will be that "minify" and "combine" options for all the files will be disabled and the site should again work as expected.

    4. Now switch on (turn to green) a toggle switch in "Minify" column for just a single file - the first one on the list; check the page if it's working as it should;

    - if it does work as it should, proceed with the next file from the list
    - if the site breaks in any way, toggle that most recently enabled switch back to "off" (gray) and skip to the next file.

    That way you should be able to minify all the files that can be minified without breaking the site, while leaving those that are causing site to break unmodified.

    5. Once you reach the end of the list, repeat the same procedure with switches in "Combine" column.

    6. Finally, repeat the same procedure with "Position" switch, where instead of "on" and "off" options you will switch it to "footer" and "original" accordingly.

    As a result, you should end up with working and as much optimized as possible site.

    Please note: it's good to disable cache on site (if there's any caching plugin installed) before doing that. Cache can seriously interfere with settings and especially with checking them.

    Kind regards,