Menu Options Not Appearing With Business Feature Theme

I thought it was a plugin issue, but it may be a theme issue. It had this on the other forum, so here is the link. In short the menu options dont appear on my web site when I activate the Business Feature theme.

https://premium.wpmudev.org/forums/topic/working-with-certain-pages-w-membership-meta-widget?replies=4#post-134299

  • JasonG
    • Flash Drive

    Hello Phil
    I appreciate the help, but please check the link to the other forum post for some history details.

    In short I am using the membership plug in. This lets me control which pages appear for the top menu navigation based the membership label of the user. But NO navigation menu appears at all anywhere in the theme Business Feature

    This has nothing to do with the Appearance>Theme Options. I want nothing to do with that. This has to do with the pages I have created that need to be controlled by MEMBERSHIP. If I change the theme to the 2011 theme, the navigation menu appears at the top as it should based on the subscription settings within membership. Load Business Feature theme and I get nothing.

    On my site, parttimeselling.com, there is a blank orange bar at the top. Should the navigation menu not appear in there?

    thanks!

  • JasonG
    • Flash Drive

    As a follow up to this I downloaded the Studio theme and gave that a shot. Same result, yet the basic 2011 theme works.

    Dont take this the wrong way WPMU, (I am not upset, just confused and want to get this done) but this should be straight forward. Is this theme compatible or not with membership? Everything is posted as 100 % Compatible, but yet I keep running into glitches and your own theme isnt working with your own plugins.

    Why does the navigation menu options within Membership NOT work with your own themes?? This is stopping me from moving forward in building this site because I cannot navigate easily around my own site.

    PLEASE HELP!

  • Tammie
    • WordPress Wizard

    I assume the issue may be you are not adding a custom menu and 2011 uses a default set of showing all pages... I can't be sure but that would be my guess. If that was the case you'd have to add a menu with the pages you wanted under appearance > custom menus.

    We've had no other user able to not use membership and menus as far as I recall (please let me know if this isn't the case anyone).

    That said I don't think membership is updated for 1.5 BuddyPress yet where our themes are - could be another variable needing to be considered here that you are mixing version themes 'if' you are using BuddyPress.

  • Tammie
    • WordPress Wizard

    I can't really understand what the issue is as those menus work and this theme works. However, it seems you have moved onto another theme which hopefully is providing you what you want. Whilst it's a shame you moved from business I understand you needed to get the site done how you want.

    We do however make sure where we can our plugins work with themes as said this would be a far larger issues and more posts if it didn't work with membership. Every case is of course different but hopefully things are on track for you now.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.