Message automatically went into Spam

I tried sending a message to a gmail account (admin email address) and got the following message:

This message may not have been sent by: abc@gmail.com Learn more Report phishing
This message was likely forged and did not originate from your account. Learn More

The message automatically went into my spam folder. Is there any way to fix this? thanks

  • Philip John
    • DEV MAN’s Apprentice

    Hiya!

    You are seeing this message because the e-mail is being sent out from the server on which your site is hosted but obviously says it's from a GMail address. As your server isn't a GMail server, you get this message as a warning.

    There is no real way round that whilst using your GMail address. You would instead need to set up e-mail alongside your existing hosting and use that or use Google Apps and set up "SPF records".

    Hope that helps,
    Phil

  • becky
    • The Incredible Code Injector

    Ok, but most of my users do not have a domain, hence they will be using free email accounts. There are other forms like si-contact form, contact form 7 or even simple contact form that sends emails to free email accounts without a problem. Your plugin will be virtually useless for a multi-site if this issue is not fixed.

  • Philip John
    • DEV MAN’s Apprentice

    This isn't actually a plugin issue but an issue with how Gmail handles e-mails where the "from" address is not associated to the server from which the e-mail is actually sent.

    There's notthing we can do in the plugin to stop Gmail picking up on that.

    Phil

  • Jonathan
    • The Incredible Code Injector

    the only way to get around it is to change the from address which obviously means that contacts sent through the site are then not "from" the person who actually sent them...

    @Phil and @Becky,

    That is exactly how si-contact handles this and i would imagine so does contact form 7.
    It creates a dummy from email account. User can insert any email address - meaning you@domain.com.

    This is the exact method that phishing / spammers use - so it works, but for how long? (Most phishing/spam ends up in the spam bin already) Shrugs.

    Here is their documentation
    http://www.fastsecurecontactform.com/email-does-not-send
    part 4 covers how they override it :wink:

  • becky
    • The Incredible Code Injector

    Hi Jonathan,

    I just checked, si-contact-form has that option but contact form 7 doesn't.

    For contact form 7, it shows email is from noreply@domain.com and the sender's email address in not in the header but in the body of the message. I don't have an email account with noreply as username.

    Comparing the 2 methods, perhaps contact form 7's method is better, for my purpose at least, so users do not need to use my domain email address to send out emails. However, it doesn't automatically create tables for multisite, hence i cant use it cos it will be too much trouble to try and activate each time a new user sign up.

    I hope contact widget plugin could be tweaked/updated to solve this issue.

  • Jonathan
    • The Incredible Code Injector

    @Becky,

    Thanks for letting me know about the contact form 7 - The way I interpret that is basically instead of giving the option to create a custom (dummy) from they just create one on behalf of the user (noreply@domain.com).

    I'm sure contact widget plugin could be tweaked to include either options, but I guess that depends on The Core Developer: VeBailovity as he will know best.

    I'll watch to see his response :wink:

  • Vladislav
    • Dead Eye Dev

    Hi,

    Thank you all for investigating this issue so well. As for the email accounts in other plugins, I believe they both just use constructed dummy accounts that may or may not correspond to the actual accounts you have set up. In the latest release (v1.3, just released) there is a similar option in the plugin, which optionally enables you to set up your emails to be sent from a generic email address at your server (the username part is editable).

  • Mark de Scande
    • Syntax Hero

    I am putting in my 2 cents and "mail" that is sent from a "server/website/blog" is noted as spam the way i always almost never get my mail set to spam is:

    First of log in to your cpanel and set up email admin@bloglines.co.za and then set up Forwarders

    admin@bloglines.co.za -> paintballcrazecc@gmail.com

    as soon as you done move over to gmail

    Log in to Gmail top right click mail setting then look for send mail from a norther email address click it add your email address admin@bloglines.co.za and click send now click the close button.

    Now just click inbox and click the link that was just sent to you.

    Now click top right again and go to the bottom and look for Signature.

    I hope this helps some out there as it helped me .

    Thx
    Mark

  • Jonathan
    • The Incredible Code Injector

    @Mark de Scande,

    Great advice and just to add that gmail limits sent emails to a max of 500 per day - so keep that in mind :wink: Not that anyone expects 500 contact emails a day, but you'd be surprised how quickly they add up depending on the users setup.

    Google = 500
    Google apps free = 500
    Google apps business = 2000 /user account

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.