Message In Defender plugin saying my sites Blacklisted Why?

HELLO I am getting a message in my Defender Plugin saying my site has been Blacklisted. I followed the instructions to fix it and let google bot crawl my site and it said nothing about it being blacklisted in my google developers dashboard after it crawled the site. So whats going on with the plugin and why is it saying this blacklisted message?

  • Adam Czajczyk

    Hello Claude,

    I hope you're well today and thank you for your question.

    The Defender's check is there for you to help you identify issues and secure the site but it doesn't affect your site's performance in any way and it doesn't affect visitors experience. Even if it says the site is blacklisted, users of the site will not be informed of that (or blocked) by Defender.

    That being said, I checked the site with several tools and it indeed doesn't seem to be blacklisted. I'm not however sure about server's IP. Do you use a dedicated IP or is it an IP that's automatically assigned by host (on shared hosting account)?

    The latter can be the cause of the issue. In case of shared hosting the same IP is often shared between multiple site out of which many are beyond your control. As a result, server's IP may be blacklisted even though your site is secure - when the other site that's using the same IP is somehow "harmful".

    I'm not entirely sure whether this is the case or not but it would be great if you could contact your host and ask them to check if their server(s) are not blacklisted as well.

    Also, please note that it may take some time for "blacklisting records" to be updated. I understand that currently Defender shows the site as blacklisted but when was it when you first noticed that and taken action?

    Looking forward to your replay,
    Adam

  • Adam Czajczyk

    Hello Claude!

    Thank you for your response.

    The dedicated IP and SSL cert shouldn't affect this. Is there any caching plugin enabled on your site or a cache on the server? If so please try clearing it.

    Also, please try disabling and re-enabling the plugin a few times to "force" it to update data. In case it didn't help please re-install it and see if that helped. It's possible that due to some unexpected "glitch" or a specific server configuration it got "stuck" with that message so this should help.

    Let me know please about the result.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.