messed up combining files

Hi,

I messed up the configuration of
There are 4 JavaScript files served from http://www.discountrxprograms.com. They should be combined into as few files as possible.
http://www.discountrxprograms.com/wp-content/themes/catalyst/lib/js/catalyst-responsive.js
http://www.discountrxprograms.com/wp-content/themes/catalyst/lib/js/navbars/superfish.js
http://www.discountrxprograms.com/wp-includes/js/wp-embed.min.js
http://www.discountrxprograms.com/wp-includes/js/wp-emoji-release.min.js
There are 2 JavaScript files served from s.ytimg.com. They should be combined into as few files as possible.
https://s.ytimg.com/yts/jsbin/player-en_US-vfla6wgHS/base.js
https://s.ytimg.com/yts/jsbin/www-embed-player-vflxURu0w/www-embed-player.js

Now the site looks funny. Can fix this issue.

Thanks,
Jeff Jackson

  • James Morris

    Hello Jeff,

    I hope you are well today.

    I'm assuming you're referring to Hummingbird rather than WPMU DEV Dashboard. So, I've changed this ticket to that section.

    Regarding minifying and combining files... Not all JS or CSS files play well being combined and minified. The reason for this is they may get combined in a way that the file added later overrides a definition in the first file. This can happen from time to time. The safest way to use the minification feature is to test each file one at a time. The following video goes through the basic steps of testing each file one at a time. https://www.youtube.com/watch?v=DxbXlV2lrfM

    The basic idea is to disable minify and combine globally, then enable it on a one-by-one basis.

    I hope this clarifies a bit.

    Best regards,

    James Morris