Meta description not being detected by the SEO checkup

SEO Checkup is not detecting the meta description, ran a plugin conflict test but got the same issue, only one site showed the description correctly and it's added in the homepage.

Access details provided in the internal ticket.

  • Ash
    • WordPress Hacker

    Hello Keith

    I can see the meta description is not even printed in the website source, that's why no online service is detecting the meta description. I have also noticed your smartcrawl SEO page doesn't have any content.

    I want to take a look at your database. I also need to run another conflict test. Is that okay with you?

    If so, would you please send me your cPanel details, as I already have your admin login?

    You can send me privately in the following format:
    1. Please go to https://premium.wpmudev.org/contact/#i-have-a-different-question
    2. Select "I have a different question" if not selected
    3. In subject line put "Attn-Ashok" (this will ensure that the email is assigned to me)
    4. Provide the wanted details.
    5. Add the thread link in the message so that I can track.

    Have a nice day!

    Cheers,
    Ash

  • Ash
    • WordPress Hacker

    Hello Keith

    Thanks for sending the DB information. But I also need your cPanel information or FTP information so that I can check the files.

    Alternatively, you can try enabling debug log and send me the log file. To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now go to the smartcrawl settings page. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,
    Ash

  • Ash
    • WordPress Hacker

    Hello Keith

    It seems a priority hiccup within the code. I have added the following code as mu-plugin and it seems working now. The added code is below:

    add_action( 'plugins_loaded', function() {
    	$seo = Smartcrawl_OnPage::get();
    	add_action( 'wp_head', array( $seo, 'smartcrawl_head' ), 999, 1 );
    } );

    Would you pleqase check and let me know?

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.