migrations issues with snapshot

I am trying to migrate a site from southernmdbuilders.com to cynthiarblack.com but I've run into some issue. The first was when trying to import the backup I got a snapshot manifest error. I found another blog post on wpmu and followed the suggestion to resolve the issue. ( https://premium.wpmudev.org/forums/topic/snapshot-manifest-error-continues-to-keep-occurring?message=closed#post-683043 ) Which was to move the backup to the new site into a new folder and then use that url in the import area. After that it said backup was now successful. Then following the original information on how to migrate by wpmu I went to all backups, clicked restore which took me to the snapshot item archive. From there the instructions say click on restore as you hover the name. There is no hover feature for me. I don't see restore on the page anywhere. Can you let me know what I am doing wrong or what to do next.
Thank You

FOLLOW UP: I realized that I needed to first run the archive. Once i did that restore appeared. But after that I got the following error message. ERROR: Unable to locate table restore file from archive: ad_commentmeta.sql

I'm not sure if it's related to the other issues above but it's the whole story. Now what??

  • Kasia Swiderska

    Hello debbien,

    From there the instructions say click on restore as you hover the name. There is no hover feature for me. I don't see restore on the page anywhere.

    Would you mind allowing support access so we can have a closer look at this? I tried to replicate on my site, but I can see whitout problem restoring option for imported snapshots.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I have to clarify that Snapshot was not created as migration tool but simply as backup. In some simple cases it can be used for migration, but its not recommended as first choice for migrating sites.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Debbie,

    I'm checking now your cynthiarblack.com site - I can see there is imported snapshot, there is link to restore on first screen - then its archive page and restore link is under the each of the snapshots (except one that is not completed)

    when you hover your mouse cursor over the name "restore" is not showing at all? Could you check another browser?
    I didn't click restore because I'm not sure which archive is correct.

    kind regards,
    Kasia

  • debbien

    Thanks for your help but I've got an issue that I don't believe has anything to do with this plugin. I've tried moving this site with other backup plugins and ALL fail. And I tried moving the site to two other servers with the same results... so it can't be servers and plugins! Then I tried simply moving the site under another domain on the same vps and it restored without issue. That tells me there has to be something different in the way the vps is creating the database originally that is giving me the problem. I don't think I know enough to figure it out from there but nevertheless this is not a problem with your plugin.
    Thanks for the help

  • debbien

    I thought I should post what the actual problem is in case someone else has this problem. It boils down to the type of database that is created on my server. The server I am on has upgraded to MariaDB instead of MySql. Not being very tech savvy I had no idea that it was different from any other database I had created. It seems there are some upgrades with MariaDB that make it incompatible with MySQL 5.1. And as far as I can tell there's no turning the clock back on the server to MySQL. So this wasn't a problem until I wanted to move one the sites in my vps to another server using MySQL. That's when the fun began!!

    For anyone having this problem there is a list of known user level incompatibilities you may see when using MariaDB 5.1 instead of MySQL 5.1. https://mariadb.com/kb/en/mariadb/mariadb-vs-mysql-compatibility/

    I hope this helps to save someone else some time and frustration.