Minification causing https errors

Hi,

Currently I am having an issue with loading my website, on a dev environment, over https.

Doing so results in several errors and this morning was causing the Upfront editor to no work at all.

I have spoken to one of my colleagues, who said the issue seems to be coming down to minification. If he turns this off there are no issues.

Would you be able to let us know why it doesn't use https if the request it's replacing uses https and if there is anything we can do about this?

Thank You! :slight_smile:

  • Rupok

    Hi Peter Rowlands,

    Doing so results in several errors and this morning was causing the Upfront editor to no work at all

    So sorry to hear the inconvenience you are having. This is really weird and should not happen. Can you please tell us in details regarding what errors are being shown? If you can copy and paste those errors here, that will give us valuable insight regarding the issue.

    Can you please also make sure your "WordPress Address (URL)" and "Site Address (URL)" both has "https://" in the box and still you are having this issue? If those values don't have "https" yet, can you please change those URLs with HTTPS and check if the issue is resolved?

    When you try to load Upfront, does it show any error or it just hangs? Can you please check your browser console for any error while loading Upfront? If you see any errors there, can you please copy and paste those here?

    Minification should not be the issue because if your source assets are loading over SSL, then your minified assets should also load over SSL. If it's not happening on your site, then we need to check your full site configuration.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know the details I requested above and confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Peter Rowlands

    Hi Rupok,

    We have made the changes as suggested and I am able to log in to Upfront and edit the website without any issues. This is with minification now turned back on.

    However, some warnings are still being produced when trying to view the site in live preview - https://dev-www.justaccounts.com

    One of the warnings being produced, for example is:
    Mixed Content: The page at 'https://dev-www.justaccounts.com/product/' was loaded over HTTPS, but requested an insecure image 'http://dev-www.justaccounts.com/wp-content/uploads/2017/01/menu-dropdown.png'. This content should also be served over HTTPS.

    Support access should also be available if you need to take a look.

    Thanks!

  • Kasia Swiderska

    Hello Peter,

    Mixed Content: The page at 'https://dev-www.justaccounts.com/product/' was loaded over HTTPS, but requested an insecure image 'http://dev-www.justaccounts.com/wp-content/uploads/2017/01/menu-dropdown.png'. This content should also be served over HTTPS.

    It looks like when you edited styles for dropdown menu you inserted path to image with http:// so now it will create those mixed messages.

    You have to edit styles and remove http: part from url so when site will load on this image site schema (https) will be used.

    Let me know if this will help

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.