Minification Conflict with Chat plugin

When Hummingbirds minification is enabled, the Tidio Chat plugin doesn't seem to load in the HomePage. Once the minification is disabled the plugin seems to work fine.

Please advise what could be done to fix this. Please check the chat notes for more info.

  • Adam Czajczyk

    Hello Thomas Sorensen

    I hope you're well today and thank you for your question!

    I checked your site and I can see the issue there so I tried to replicate it on my end. However, Asset Optimization didn't affect the chat in any way on my test sites. Regardless of the AO settings it was working fine.

    That would man that the issue only reveals itself under specific conditions so its either related to server or your site's setup.

    That said, are there any caches on server? If yes, please try clearing them and disabling and then try setting up Asset Optimization again. If there's kind of CDN it might be worth disabling or putting into "dev" mode (if possible) temporarily to check if that affects the issue.

    The essential test, however, would be a full conflict test. It would mean keeping the chat plugin enabled, disabling every other plugin and then re-setting Asset Optimization and checking if the chat is working. If yes, then enable back one of disabled plugins, re-set AO and check again and so on until it breaks and that would hopefully give us a clue where the conflict is:

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Could you please perform such test and let me know about results?

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.