Minification is stuck at 10%

Max_execution_time is set to 90, PHP memory to 256M

Debug.log not created. Error.log showing only notices.

Yesterday the minification was working well. The power was cut off and after this, the Minification stuck

  • Mahlamusa

    Hello yesoye,

    I hope you are doing great today. I am really sorry about the inconvenience you are having with Hummingbird and I hope we get it resolved soon.

    I have tried to access your WordPress Dashboard using the login credentials you shared but unfortunately I wasn't able to login. I then logged in to your cPanel and checked the error logs and found something that could lead us to a solution.

    PHP Warning: ini_set() has been disabled for security reasons in /home/yesoyeco/public_html/wp-includes/load.php on line 330

    This is a warning it may seem it has nothing to do with Hummingbird working but the 'ini_set' PHP function is used by WordPress to set values like memory limit and other useful PHP values essential for WordPress Core, Plugins and Themes to run properly. The most important feature that uses this function in WordPress is the constants:

    define('WP_MEMORY_LIMIT', '256M'); //used by front end
    define('WP_MAX_MEMORY_LIMIT', '256M'); //used by WordPress back back end/ admin

    If you set those constants to define or raise the memory limit, then WordPress will internally use the 'ini_set' function to set the values in those constants like so:

    @ini_set('memory_limit', '256M');

    So if ini_set is disabled then those constants will be useless and PHP will add the above PHP Warning in debug/error log.

    I have noticed that debug logging has been enabled but no debug.log file is saved, this again is because of the ini_set function. As I said earlier the WordPress constants to enable debug logging are not effective because they depend on the ini_set function which is disabled in your server.

    Usually, it is the Host who disable this PHP function as a security measure. If Hummingbird is not working properly as yet then please contact your host and try to find out if they can enable that function or provide a way to set PHP variables like memory_limit, max_execution_time and others.

    I have seen that memory_limit has been set in the 'php.ini' file but I could not verify if it is useful or not because when trying to use the 'phpinfo()' function in a 'info.php' file, I get a blank page which is another sign that this function as well is disabled by your host. So, I am not sure which values are currently set. So please, ask your host to set the following values as minimums for WordPress and its plugins to work properly.

    memory_limit = 256
    max_exection_time = 150
    max_input_time = 60

    Please set this values either in your php.ini file or ask your host to set them for you in your website. This values might be the cause for WordPress and Hummingbird not to work properly if they are set too low.

    I hope this helps you, if you do not understand what I am saying then contact your host with a link to this thread and they will understand and give you a way forward.

    Have a nice day.
    Mahlamusa