Missing Roles In All Sub-domains

I can't see and of the sub-domains in the network admin. When I click on "My Sites" it is empty. When I go to the sites section in the network admin all sites are still there. Additionally, when I go into a sub-domain the users are empty and the user role drop-down is empty.

Support access has been granted.

  • Adam Czajczyk

    Hello Thomas,

    I hope you're well today and thank you for your question!

    I accessed and reviewed your site and I'd say that the case here is:

    1. users are registering on your main site so they become user of that main site only
    2. sub-sites were created either by you manually or using some kind of automation and the "admin" user has been removed.

    As for #1

    On WordPress Multisite users do not get access to main site and all sub-sites of the network after registration. Instead they become users of that particular site that they registered for only. This would explain why there's no more users for other sites than main one. This can be changed with this plugin:

    https://wordpress.org/plugins/multisite-user-management/

    With it installed user that registered for any of the sub-sites of the network gets an account (and predefined user-role, you may select it for each site separately) on all other sub-sites.

    As for #2

    This is weird indeed. Could you please tell me how were these sites created and if you did remove any users manually?

    I can also see that there's a User Role Editor installed on your Network but there's no way to trace how was it used so far. Could you then elaborate a bit on how do you use/used it?

    Best regards,
    Adam

  • Thomas Edgell

    Adam Czajczyk I created all of the sub-domains via the Network Dashboard. I have always had access before. You can look at the other multi-site oncenetwork.com (access granted) and you will notice that I am not only the super admin but also an admin on each sub-domain. That was done automatically by the standard multisite install. Nothing was done manually. That is not the case any more on leadwithanedge.com. No users were manually deleted and the user role editor was only installed and has no custom configuration.

    Since I am not an admin any more, on any of the sub-domains, they don't show under the my sites and I can't access the admin pages for those sub-domains.

    Obviously looking for a solution asap. Ty for taking a look at this challenge.

  • Predrag Dubajic

    Hi Thomas,

    Thanks for providing additional info, I tried using defender DB prefix change and that didn't made any change for users on my site.

    I'm however not sure if this might be the issue on your end since it does look like user tables are empty.
    And when I access one of your subsites admin section the super admin was added to that subsite and it started showing in My Sites section as well, even though I didn't made any changes, literally just opened dashboard in subsite.

    Do you have backup of the site before the prefix change you can revert to and check if that was the cause?

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Thomas!

    I accessed your "leadwithanedge.com" site again and checked it's database using an "Adminer" plugin (which I already removed for security reasons). It seems that those missing user roles may be indeed a result of wrong option name. I'd like you to follow the steps below in order to try to fix it:

    1. Access site's database using phpMyAdmin (don't do this using Adminer plugin because you would then lock yourself out of the site!)

    2. use phpMyAdmin Export option to export "lwae_options" table (including data) to a file in order to have its backup at hand in case these steps didn't work; please make sure that you completed this step before proceeding, it's extremely important!

    3. find this table "lwae_options"

    4. in this table find a row with "option_name" value of "lwae_backup_user_roles" ("option_value" value should be empty there)

    5. delete that row

    6. in the same table find a row with "option_name" value of "wp_backup_user_roles" and change that value to "lwae_backup_user_roles"

    7. in the same table find a row with "option_name" value of "wp_user_roles" and change that value to "lwae_user_roles".

    That's of course assuming that I correctly identified database and this site is indeed using "lwae_" prefix (I'm mentioning this only because there are more tables in the same database using different prefix).

    Once above steps are complete please check your sub-sites if user roles are now available again.

    In case any of this caused issues or even locked you out of the site, please restore "lwae_options" table from backup file created in step 2.

    Let me know if this worked for you, please!

    Best regards,
    Adam

  • Thomas Edgell

    Adam Czajczyk I hope you are doing well sir.

    I apologize for the delay in responding. It has been a crazy week. It appears that you looked while I was in the middle of modifying the database. I found many tables in the user_metadata table with the default prefix. I have changed those default table prefixes and will monitor if that has caused any other challenges by using the other multi-sites as a model.

    I have also found that each of the sub-site options tables had an option name that needed to be changed from wp_sitenumber_user_roles to lwae_sitenumber_user_roles. Completing all of these actions has brought back the user roles for each sub-domain, the listing for the My Sites in the drop-down menu in the top admin bar and made the role editor work again.

    Thank you for being such a valuable part of our team. The membership and the support you provide is well worth the subscription price.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.