Missing work with Grand Photography Version: 2.3 By ThemeGoods


I was working on a specific page of my website, http://hummelcreative.com/wp-admin/post.php?post=5252&action=edit, and I was trying to add additional content. When I went to hit the plus sign to add additional content, all of the content I had in there previously disappeared.

I tried going back to an older revision, and it wouldn’t go. How do I get my work back? What did I do wrong that made this happen?

Please help.

Thank you!


  • Rupok
    • Support Ninja

    Hi Maria,

    So sorry to hear the inconvenience. The link you shared is only accessible when logged in. So I can't have a look at your page editor. And Grand Photography is a third-party paid theme and I'm afraid, I don't have any access to its architecture. So can't confirm if this is possible to get back the previous content if that was created with any custom builder coming with that theme.

    As a quick workaround, can you please check your page editor for that page and search for revisions? Please check the attached screenshot for reference.

    If you see the revisions there, then you should be able to restore any previous revision for that page.

    Actually, I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:


    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!


  • Maria
    • New Recruit

    Hi! Thank you so much for responding! I have tried going back to older revisions, and unfortunately, it doesn’t resolve the issue. For some reason, I can’t go back to older revisions even though I can see exactly how many I have, and literally click the button, restore to this revision. :disappointed:

    I have granted support access to my site.

    Thank you so much for your help!


  • Kasia Swiderska
    • Support nomad

    Hello Maria,

    From what I see revision is restored, but to see that you would need to switch back to the classic editor

    When restoring revisions code there changes. But Visual Editor is not pulling that content – I did small test on another page to see how this builder works and I think I replicated issue you had. I created page, started to add content and tried save as draft, but it failed and I was back to empty builder.

    I'm not sure how this builder works, but it seems it saves state of what is in builder and something goes wrong while saving, it its lost – then it doesn't pick up the actual content that is in text editor.

    This is or problem with another plugin (I suggest running quick plugin conflict test as illustrated in getting support manual (flowchart) http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/) or issue with the builder itself and in this case you will need to get in touch with the theme developers.

    kind regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.