Mixed content error non secure site

Unable to get secured logo on browsers. Site has SSL certificate setup properly. I am getting mixed content error in the console.

  • Dimitris
    • Support Star

    Hello there Brandon

    This seems like a caching conflict as I am not able to see the mixed-content errors while I'm logged in but they are visible only for not logged-in users.

    By checking the HTML markup of the homepage I see a line like:
    <!-- Cache Enabler by KeyCDN @ 09.08.2019 16:25:23 (html) --> and also when going to Plugins -> Must Use I see a CS Cache Enabler plugin listed there.

    This seems to also conflict with Hummingbird -> Caching -> Page Caching as there's this message showing there:

    Hummingbird detected an advanced-cache.php file in wp-content directory. Please disable any other caching plugins in order to use Page Caching.

    I'm not sure from where this other caching plugin is coming from, let me know if there's any way to purge/clear that caching. Another workaround would be to remove it altogether (both the MU plugin and the wp-content/advanced-cache.php file) and re-check Humminbird's Page Caching that started working well. This should then resolve the mixed-content issues for the not logged-in users as well, as caches will be re-created based on the actual non-cached pages.

    Looking forward to your results! :slight_smile:
    Warm regards,
    Dimitris

  • Nahid
    • Tech Support

    Hey there Brandon !
    Hope you are doing well today!

    I took a look at your site and as a not logged-in user, I wasn't able to see any mixed content errors in the site as well. Here's a screenshot for reference:

    Are you still able to replicate the issue on your end? If you do not have an ability to purge or clear cache, would your host be able to do that for you?

    We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.