Mobile just not getting it.

1)I am having difficulty with the featured image on the home page displaying. It displays on Chrome, does not on my Safari.
2) when viewing on mobile, both IOS and Android images often do not display.
3) Buttons are aligning and sizing irregularly on mobile

  • Rupok

    Hi crossconnecting,

    Let me describe your issues one by one:

    1)I am having difficulty with the featured image on the home page displaying. It displays on Chrome, does not on my Safari.

    I opened your site in my Safari browser in Mac OS X 10.10.5 and the featured image on homepage is displaying fine. So I could not regenerate the issue on my Mac. Please check the attached screenshot for reference.

    Is there any specific steps I should follow for regenerating the issue on my end?

    2) when viewing on mobile, both IOS and Android images often do not display.
    3) Buttons are aligning and sizing irregularly on mobile

    Well, at first I could not regenerate this, all was working fine. Please check the attached screenshot for reference.

    Then after couple of refresh, I got an error on console saying one of your Upfront Dependency CSS is not loading from server:
    https://frontline.supply/upfront-dependencies/styles/8ab3194f1f1bdb5a7b757a1780bc3ad0?ver=1.1.2
    And when this CSS file is not loading, your menu, header image and buttons all are breaking. Can you please try adding the following line in your "wp-config.php" file and check if it helps?
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');
    To add this line in "wp-config.php" file, login to your server with any FTP Application like FileZilla and go to the root folder of your domain. There you will get this file. Download that file, add this line, save and upload again replacing the old file. This will do.

    Please let us know how it goes. We will be glad to investigate further if it doesn't resolve this issue.

    Have a nice day. Cheers!
    Rupok