Moderation plugin is not working with wpmu 2.8.4a

Moderation plugin is not working anymore for wpmu 2.8.4a! When you click on report this post in a blog’s post, the ajax popup effect only show empty white blank box! Testing can be done at http://blogmyway.org/bv2/bangbang/ to reproduce the same error. I had all the files in moderation plugin in the correct place: For example, I have

moderation-framework.php – goes in /wp-content/mu-plugins

moderation-admin – goes in /wp-admin/

warning.php – goes in /wp-admin/

moderation.js – goes in /wp-content/

So it must be the plugin is not working!

  • argh2xxx
    • The Incredible Code Injector

    The thing about mod_security is that if using too strict rules, then you got a problem of usability, and if you’re using too lax rules, it’s like not using it at all. Also, I noticed it’s super super complicated to pick which rule to use! Trusting the source of rule creator, and using the whole package, or removing specific rule by checking error_log, but the thing is that if you got a busy website, it’s you that have to pull out hairs to see which rule created the problems. Though, at the very least, I know the culprit is mod_security, and it’s not the plugin itself! :slight_smile: Great work as always! Keep up the good service Andrew!

  • hollysuso
    • Design Lord, Child of Thor

    Maybe I’m misunderstanding the purpose of moderation. If someone comes to my site and creates a blog, posting, or comment, it’s supposed to land in this cue before going live right? If that’s true, it’s not working on my site. I’ve had several blog sign ups, post, and comment on my site that went right by me. What do I do?

    http://www.mymompreneur.com

    WPMU 2.9.1.1 w/Buddypress

  • Sue
    • Recruit

    No that isn’t correct. It is designed so that users and readers can click on the Report This Post or Report this Comment link at the bottom of a post or comment and submit a report to say the comment or post is inappropriate.

    This places the post, comment or blog in the backend management queue and allow a moderator to take the appropriate action.

    If you want to moderate all posts and comments before they are published then you need to use a different option.

  • firedoglake
    • WPMU DEV Initiate

    Hi. I've got the moderation plugin installed on my site. On my staging server I am getting a similar issue to the original poster on this thread: click on the "Report this.." link and the lightbox pops up, with the title bar but no form to fill out. In my local devel environment the form shows up fine. Any brilliant ideas for tracking down the discrepancy?

    It's a 3.0.1 multisite installation. I've checked the server logs and don't see anything happening there.

    Here are some more details on what's I've tried:

    I checked the wp_register_script function, and the moderation script is getting added to the WP_Scripts object, but nonetheless, when I click "report this .." I get an error in chrome's devtools console saying it failed to load the "/blog?moderation_action=report_form... (etc)"

    I've never used wp_register_script before, I've always used the wp_ajax_ action.

    Ok, I guess I'll go start disabling plugins (though the two installs — local, and staging — are mirrors).

    Thanks,

    Bethany

  • Mason
    • DEV MAN’s Sidekick

    Hiya Bethany,

    That’s definitely odd (especially working on one environment and not on the other – so annoying!) and we haven’t had any reports of this trouble recently.

    If this continues to be an error (after disabling all plugins) will you open a new thread and post your issue there. You can link back to this thread if ya like, but that’ll help us keep the threads shorter so we can respond more quickly!

    Thanks! :smiley:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.