Modification impossible. ERROR 502 Gateway

I want to change my settings Chat but its not working. It redirects me to a 502 error Gateway.

How to solve this problem?

Thank you !

  • Timothy Bowers

    Hey there.

    Can you try clearing your cache please.

    You can read more here:

    http://www.checkupdown.com/status/E502.html

    Fixing 502 errors - general

    This problem is due to poor IP communication between back-end computers, possibly including the Web server at the site you are trying to visit. Before analysing this problem, you should clear your browser cache completely.

    If you are surfing the Web and see this problem for all Web sites you try to visit, then either 1) your ISP has a major equipment failure/overload or 2) there is something wrong with your internal Internet connection e.g. your firewall is not functioning correctly. In the first case, only your ISP can help you. In the second case, you need to fix whatever it is that is preventing you reaching the Internet.

    If you get this problem for only some of the Web sites you try to visit then it is likely to be a problem at those sites i.e. one of their pieces of equipment is failing/overloaded. Contact the people at those sites.

    And here:

    http://pcsupport.about.com/od/findbyerrormessage/a/502error.htm

    Has your host said anything about this 502?

    Let me know.

    Take care.

  • Paul

    @Antoni,

    Touching back with you on this 502 issue. I'm assuming this might be because Chat attempts to communicate with its own AJAX file located in the plugins file and not the default WP AJAX file in wp-admin/admin-ajax.php This is generally the hosting or some security plugin preventing AJAX communications.

    You can control this. In wp-admin go to Chat > Settings Common. Then on the tab 'Chat Sessions Polling Content' set the dropdown to use 'WordPress AJAX'. See image. Then save the settings and reload the front-end page.