Modify appointments+ admin options & more

Here are some suggestions I think lots of folks would benefit from:

An easy way to change the words found in the appointments.php without needing to open the file and edit it like “Select a Service”. I want to change the word Service to Fishing Vessel and Provider to Captain. I can also see this used as a Tee Times & other reservation system. Therefore, on a WP Network it would be helpful to be able to modify this on a per blog basis. If you set it in the Appointments.php it will go Network wide.

Making it easy to change words like “OUR SCHEDULE FOR AUGUST 2013” to a larger or bold font or H1 etc.

Adding a feature to allow use of Appointment Calendar across various sites / blogs on a Network. For example, a Fishing Vessel and Captain may want a website on our Network. It would be great to be able to just add his Fishing Vessel calendar to his site / blog on the network so it would sync with the main site on the Network. We are looking at over 20 fishing vessels on the main calendar so he would not want the competition on his particular site on the Network.

  • Alexander
    • DEV MAN’s Mascot

    Hi there @lubyg,

    Many of the titles can be changed simply by using the shortcodes provided. You can edit your “Make an Appointments” page and add some shortcode parameters. For example:

    [app_services select=”Select a Shipping Vessel”]

    [app_service_providers select=”Please select a Captain”]

    Making it easy to change words like “OUR SCHEDULE FOR AUGUST 2013” to a larger or bold font or H1 etc.

    Appointments+ has a field where you can save custom CSS rules. Here’s a CSS rule you could start with to change the text you’re looking for:

    .appointments-wrapper h3 {
    font-weight:bold;
    font-size: 24px;
    }

    About the last feature. That’s definitely an interesting idea. I know it’s not possible at the moment, but I’ll move this to the feature request section so it could be considered, and reviewed.

    Best regards

  • LubyG
    • Site Builder, Child of Zeus

    Thanks Alexander for the quick reply. I am sorry I missed all those options. It is a bit overwhelming but worth it. I really like the potential of this plugin. Glad I was able to give one good suggestion out of three :slight_smile:

  • Alexander
    • DEV MAN’s Mascot

    @lubyg, sure thing! There’s definitely quite alot going on with this plugin, and there’s more on the way! We have a new update coming out soon that will bring some pretty great improvements with it including a new permissions system.

    Thanks for your feedback!

    Best regards

  • LubyG
    • Site Builder, Child of Zeus

    Just installed the update today and things are lots better. One thing I noticed the other day still needs fixed unless I missed it.

    The Service Provider widget shows the WordPress user name for logging in and not the Nickname nor does it pull from the My Name field in the Profile.

  • pxwm
    • WP Core Meltdown

    Hi @alexander Rohmann – Hope you don’t mind me chiming in.

    Hi @lubyg

    I’m sure this option is available in v1.3

    Login to your WordPress dashboard using Admin

    Select A+ settings

    Select the ‘Add-ons’ tab

    Then activate ‘Service provider names’

    I haven’t tried it yet but the history log indicates that it will allow you to set the Service Provider name.

    Hope this helps

    Regards

    SteveB

  • LubyG
    • Site Builder, Child of Zeus

    Hi pxwm. Nope, that does not seem to do it. I’ve got names that make sense in the Profile as Nickname, My Name under Appointments + and at the bottom under WordPress SEO settings.

    Unless you can think of another area where this might be found I’m at a loss. Not a real big problem as I don’t need to use that particular Widget. It would be nice but not necessary.

  • pxwm
    • WP Core Meltdown

    Hi @alexander Rohmann

    I would appreciate if you could investigate this feature in v1.3.

    I’m currently attempting to regain access to my settings and If I’m successfully I’ll post the solution

    *****WARNING****

    I’ve just tried the following on my demo site and it seems to block me gaining access to the A+ settings after making a change to one of my Service Provider name options.

    The message I receive is: You do not have sufficient permissions to access this page.

    Hi @lubyg

    Could you please confirm the following:-

    Are you using A+ v1.3?

    If so have you activated ‘Service provider names’ in the A+ ‘Add-ons’ tab

    If you have could you:-

    Login to your WordPress dashboard

    Select A+ settings

    Select ‘General’ tab

    Scroll down to the ‘Advanced settings

    Then select the most appropriate settings from the dropdown in the relevant field.

    Save the settings

    If you then logout and check the appointment page this should display this name in the:

    Service Provider dropdown field

    Appointment form

    any emails sent

    Interestingly I’ve tried the above without the ‘Add-on’ activated and selected the most appropriate user name from the WordPress ‘User’ profile and this seems to work.

    You mention in your post you are using a Service Provider widget. Could you please confirm how you have activated this?

    Regards

    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @alexander Rohmann

    Just to confirm I’m logged in as Admin which is NOT a Service Provider and then try to select A+ Settings and I get the message:-

    ‘You do not have sufficient permissions to access this page.’

    I’m still testing but would appreciate if you could investigate as it appears there may be a problem with this Add-on feature or it maybe a problem with this feature and the A+ log-in permissions feature.

    Regards

    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @alexander Rohmann

    Further update

    I’ve taken a backup of the site and database

    I then uninstalled the plugin and re-installed v1.3 as a clean install

    I could then access the A+ Settings page.

    I then uploaded the database with all the A+ Settings and tried to access the A+ Settings page and it presented the message:

    ‘You do not have sufficient permissions to access this page.’

    I would therefore suggest there is a database conflict between the WordPress user profile permissions and A+.

    Regards

    SteveB

  • Alexander
    • DEV MAN’s Mascot

    @pwxm

    Hi @alexander Rohmann – Hope you don’t mind me chiming in.

    Not at all! I most certainly appreciate it!

    The Service Provider widget shows the WordPress user name for logging in and not the Nickname nor does it pull from the My Name field in the Profile.

    Confirmed. I’ll mention this to the developer so he can take a look.

    @pxwm

    I’ve tried the “service provider name” add-on and everything is still working ok for me. Do you have any other add-ons enabled? Or do you have any other idea what I can try to reproduce it? I’ve been playing with it for a but here and haven’t gotten it to break yet.

    Best regards

  • Alexander
    • DEV MAN’s Mascot

    @lubyg,

    Yes, this is what I was confirming. When using the widget it pulls directory from the username, so it may not end up showing that service providers actual name if their username is different. I’ve gotten in touch with the developer to see if he has any feedback here. There might be a way to change this, or perhaps it can be considered for the next release to improve the widget.

    Best regards

  • pxwm
    • WP Core Meltdown

    Hi @alexander Rohmann

    Thanks for that.

    I can confirm I don’t have any other plug-ins activated.

    I do have another demo site so I will take a full back-up and then upgrade to v1.3 and then complete a 2nd back-up and then activate the ‘service provider name’ and see if I can break it.

    Do you want me to continue with this post or create a new one?

    Regards

    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @alexander Rohmann

    I can confirm I can break it by doing the following:-

    Install A+ v1.3 as a clean install using WordPress 3.5.2

    No other plugins

    Then select A+ Settings

    Then Select ‘Add-ons’ tab

    Then activated ‘service provider names’

    Then select A+ ‘General’ tab

    Then selected Last Name, First Name in the principle and left the fallback as default and saved

    Then selected another WordPress menu option

    Then selected A+ Settings and it allowed me into the page

    I then selected ‘Add-ons’ tab and activated ‘administrative permissions’

    I then selected A+ ‘General’ tab and scrolled down and changed the service provider name in the principle field back to default.

    To confirm I left the ‘administrative permissions’ settings as default

    I then selected A+ Settings and it would not allow me in giving the message:-

    “You do not have sufficient permissions to access this page.”

    It would appear that the ‘administrative permissions’ Add-on is denying access even to the main site admin (this is a single WordPress site)

    The only way I can restore permissions is to re-upload my saved database.

    Hope this helps resolve the problem

    Regards

    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.