Modifying single post layout CSS

Dear Support,
I have previously received help modifying single post views here:
https://premium.wpmudev.org/forums/topic/modifying-the-post-element-template#post-857343

The changes need to be made to single post article pages that are generated by AutoBlog.
Everybody’s help has been great thus far but a few more changes are necessary.

1) I would like the post title to link back to the URL of the original article, not the post active post itself - BUT also have the link open in a popup via the AutoBlog ‘open in popup’ add-on.

2) The Read more / Continue reading link seems to have vanished from many posts. Does anybody know what style represents that link and how to turn it back on?

3) While editing single post pages in the Upfront editor the comments box is yellow with a white content area. For some reason the styling is gone when the page is viewed live. How do I restore the default style and or change the color?

4) By default the posted article displays a short excerpt above the article. I would like to hide the excerpt, it is redundant as the beginning of the article under it shows the same content.

Cheers,
Thomas

  • Predrag Dubajic

    Hey @Thomas Sarkisian,

    Hope you're doing well today

    1) I would like the post title to link back to the URL of the original article, not the post active post itself - BUT also have the link open in a popup via the AutoBlog ‘open in popup’ add-on.

    If I understand this correctly you want popup to open by clicking on post title?
    If that's the case this is not currently possible with the plugin as the posts are imported to your site and thus link to their respective pages.

    2) The Read more / Continue reading link seems to have vanished from many posts. Does anybody know what style represents that link and how to turn it back on?

    Can you tell me where is this happening, I'm able to see all read more links as you can see in the screenshot attached, is it something browser related?

    3) While editing single post pages in the Upfront editor the comments box is yellow with a white content area. For some reason the styling is gone when the page is viewed live. How do I restore the default style and or change the color?

    If you go to custom CSS rules you will see this code which is affecting comment section and you can change it from there:

    .comment-respond {
        background: #ffe262;
        padding: 30px;
        overflow: hidden;
        margin-bottom: 20px;
    }
     .comment-respond p {
        margin: 0 0 1px 0;
    }
     .comment-respond input,  .comment-respond  textarea {
        width: 100%;
        height: 52px;
        border:none;
        padding: 15px;
        resize: none;
        box-sizing: border-box;
    }
     .comment-respond  textarea {
        height: 145px;
        padding-left: 15px;
    }
     .comment-respond input[type=submit] {
        float: right;
        padding: 20px 45px;
        background:#fed41d;
        border: none;
        width: auto;
        line-height: 0;
        margin-top: 20px;
        font-weight: 700;
        font-size: 15px;
    }
     .comment-form-author,  .comment-form-email {
        margin-bottom: 3px!important;
    }

    4) By default the posted article displays a short excerpt above the article. I would like to hide the excerpt, it is redundant as the beginning of the article under it shows the same content.

    In your CSS rules I have added this CSS code to hide the excerpt on single posts:

    .single-post .upfront-postpart-excerpt {
        display: none;
    }

    Best regards,
    Predrag