So I wanted to change my shopping “cart” to a shopping “bag” and I managed to do that through a few find and replace edits, but it would be great if in future versions – since I know those changes will be wiped and I’ll have to make the edits again, you would NOT HARDCODE certain terms. I know it seems like a minor thing, but I’d imagine quite a few people would like to call it a shopping basket or shopping bag, or just bag, etc. and with the current system that’s not possible in a future proof way.
Please consider making certain things user-defined instead of hardcoding them.
That I’ve changed so far
1. Shopping cart – needs flexibility on what it’s called
2. Coupon code – someone in the UK may want to call it a voucher code, or discount code or anything else. Fine to call it that on the back end, but it shouldn’t be hardcoded for the store view.
3. Checkout flow – it wouldn’t be as easy as defining text for the cart and coupon code names, but if people want to test a single page checkout, or consolidate items, more control over the checkout would be good.