more headaches

More headaches....after this, https://premium.wpmudev.org/forums/topic/bp-corporate-update-for-bp-15-killed-my-site

I simply rolled back to the previous version until a fix is in. Not a big deal. But once I reactivated the older version, now I can't get control over my navigation bar. See the screenshot. All the BP items are there, and the nav has been hijacked.

Normally, simply setting the menu in Appearance -> Menus fixes this right away. What did I miss?

  • DavidM
    • DEV MAN’s Mascot

    Hi Saunt,

    The screenshot doesn't appear to have gone through, can you try posting that again?

    Also, you're using a child theme of BP Corporate correct? If you create a menu from scratch and set that as your menu, does that do anything?

    Thanks,
    David

  • Saunt Valerian
    • The Bug Hunter

    I've remodeled a little so I can get my site back online, but I've created a temporary menu from scratch (as u asked) and the results are here (though it isn't exactly what I want - it's more of a workaround):

    Home and Activity are part of the BP hijacking. The Community item is added in (as an option by BP Corporate) and the Marketplace and Search are the menu I've chosen. I had to turn off my forums because the way the hijacking added them to menu (displayed the page title - which was ugly in the menu)

    I've never had this problem before when I installed this theme the first time. Setting a custom menu overrode the hijacking. I also did a little plugin dance too, and also deactivated/reactivated BP to see if that fixed it. Still nothing.

  • DavidM
    • DEV MAN’s Mascot

    Hi Saunt,

    If you're referring to the Home and Activity items added to the menu, you can remove them by removing lines 19-25 from navigation.php in the theme folder.

    Those same items should have shown up by default in your previous use of the theme so I'm not sure why the difference now.

    Do you have a navigation.php in your child theme that excludes those lines? If not, can you add that into your child theme?

    Thanks,
    David

  • Saunt Valerian
    • The Bug Hunter

    Thank you David, for pointing me in the right direction. This has been a tough day - your quick response is greatly appreciated.

    I don't remember having to do this before when I first installed the theme, and I couldn't find a forum thread here of me asking for help, so not sure why it seems different this time. Anyhow, putting a modified navigation.php into the child theme seemed to have no effect, so I ended up cutting out the snippets of code from the navigation.php that is in the parent theme. Not the best method, but I'll be updating all this next week anyhow when I go through the upgrade to BP 1.5.

    Thanks again, David. It is the quick responses from you and others who monitor these forums daily which make membership here worthwhile!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.