More Issues With Membership Plugin-New Members Cannot Sign Up

I thought it strange that I have not had any new members sign up for my Membership site, as I usually get 2-3 new members every week. But, since the new release–nada.

So, I tested it myself. Attached is the screen that I get after I choose a subscription plan (I use 2Checkout)

I have no idea how many members I have lost, and I must say my frustration with this plug in is reaching it's limit. I have had problems with it for over a year now, and keep hearing promises of fixes. I have spent hundreds of hours doing manually what this plugin should do automatically. But, losing members hits me in the pocketbook.

I reverted (again) back to an older version. The 2Checkout issue of not updating cancellations and expire dates still exists with the new and the old version.

Please let me know if these issues can or will be solved.



  • Kimberly
    • Champion of Loops


    I am so sorry you are still having trouble! I can only imagine your frustration, I will see if I can help get you sorted out

    The Error you are seeing is usually because there are spaces, new lines, or other stuff before an opening <?php tag or after a closing ?> tag, typically in wp-config.php. In this case it seems as if your header.php is causing the trouble (referring to the first line referencing a fileinf the error). The remainders are likely an avalanche effect. Once causing all of the others from the top down. Replacing the faulty file with one from your most recent backup or one from a fresh WordPress download is your best bet, but if neither of those are an option, please follow the steps below.

    Just because you cannot see anything does not mean that PHP sees the same.

    Download the file mentioned in the error message via FTP or the file manager provided in your host’s control panel.

    Open that file in a plain text editor (NOT MS Word or similar. Notepad or BBEdit are fine).

    Check that the very first characters are <?php

    Check that the very last characters are ?>

    To be sure about the end of the file, do this:

    Place the cursor between the ? and >

    Now press the DELETE key on your computer

    Note to MAC users: The “DELETE” key on a PC deletes characters to the right of the cursor. That is the key noted here.

    Keep that key pressed

    For at least 15 seconds

    Now type > and

    save without pressing any other key at all.

    If you press another key, you will bring the problem back.

    Upload the file back to your server after editing and saving the file.

    Other issues that might cause that error:

    In case you’ve used the function: wp_redirect() or tried to use a header redirect after the header (or any content at all was sent) that error message will pop. Instead use javascript redirection if needed.

    Please let me know if this helps! If not we will investigate any other causes :slight_smile:



  • JoAnn
    • The Incredible Code Injector

    Okay, against my better judgement I reinstalled the new upgrade to the membership plugin and I get that same error when I try to sign up. Here it is:

    Warning: Cannot modify header information – headers already sent by (output started at /home/sisterh0/public_html/wp-content/themes/business-portfolio/header.php:2) in /home/sisterh0/public_html/wp-includes/pluggable.php on line 669

    Warning: Cannot modify header information – headers already sent by (output started at /home/sisterh0/public_html/wp-content/themes/business-portfolio/header.php:2) in /home/sisterh0/public_html/wp-includes/pluggable.php on line 670

    Warning: Cannot modify header information – headers already sent by (output started at /home/sisterh0/public_html/wp-content/themes/business-portfolio/header.php:2) in /home/sisterh0/public_html/wp-includes/pluggable.php on line 671

    Warning: Cannot modify header information – headers already sent by (output started at /home/sisterh0/public_html/wp-content/themes/business-portfolio/header.php:2) in /home/sisterh0/public_html/wp-includes/pluggable.php on line 866

    I need to know how to fix this, and why it is happening. I really don’t think I should have to go poking around in the code to fix this. I am using the Business Portfolio theme that I downloaded from you.

    These should be compatible, don’t you think?


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.