More ProSites Payment issues

I tried to transfer pro site status from one blog to another and I got this error message -

Fatal error: Uncaught exception 'Stripe_InvalidRequestError' with message 'Unrecognized request URL (GET: /v1/customers/). Please see https://stripe.com/docs or we can help at https://support.stripe.com/.' in /public_html/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe-files/lib/Stripe/ApiRequestor.php:147 Stack trace: #0 /public_html/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe-files/lib/Stripe/ApiRequestor.php(268): Stripe_ApiRequestor->handleApiError('{\n "error": {\n...', 404, Array) #1 /public_html/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe-files/lib/Stripe/ApiRequestor.php(109): Stripe_ApiRequestor->_interpretResponse('{\n "error": {\n...', 404) #2 /public_html/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe-files/lib/Stripe/ApiResource.php(30): Stripe_ApiRequestor->request('get', '/v1/customers/', Array) #3 /public_html/wp-content/plugins/pro-sites/pro-s in /public_html/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe-files/lib/Stripe/ApiRequestor.php on line 147

The status does say that it has transferred, however I'm not convinced that the PayPal profile actually is now linked to this new site rather than the old one. The status was being transferred to site ID 87 from site ID 84. Strangely, the error message is for Stripe, even though this was a PayPal linked account. Thoughts?