Most of Themes outdated ... :-(

Hi there,
it's really a disappointing experience to notice, that most of the themes of this package are outdated, some of them even since WP 2.8., as we receive error messages such as:
Notice: get_the_author_ID is deprecated since version 2.8! Use get_the_author_meta('ID') instead. in /var/www/web549/html/_wordpress.multi/wp-includes/functions.php on line 3201
Notice: get_current_site_name is deprecated since version 3.9! Use get_current_site() instead. in /var/www/web549/html/_wordpress.multi/wp-includes/functions.php on line 3201

Honestly speaking, we have expected something more exciting from the makers of Wordpress!