Moved my multisite to a different server, now all images don't show on blogs

Hi There,
Today I moved my multisite to a cloud server. I'm just ironing out some of the creases from the move, but one thing I can't figure out is why the images won't show in my sites (except for the primary blog).

What's strange is the files appear to be in the right place, for example, I can go to http://www.structiv.co.uk - the original url for this is structiv.skizzar.com but has been mapped. If I right click on the broken images, I can see the path of the image is correct, i.e. the image does exist in the directory - So I can't figure out why they are not showing.

I would appreciate if you could take a look for me and help me trouble shoot this issue.
Thanks
Sam

  • Samuel

    Hi @Luis,
    Sorry let me explain a little more, so regarding the main site - everything works fine from a media point of view - this issue just resides with blogs other than the primary one.

    If I go to media > Library I see blank holding images where the actual images should be:
    http://awesomescreenshot.com/0ec5iuu25a

    If I upload media, it uploads successfully, but just shows as a holding image:

    http://awesomescreenshot.com/04f5iuu8c2

    My site is a subdomain install here is my .htaccess.

    <IfModule mod_headers.c>
        Header set Access-Control-Allow-Origin "*"
    </IfModule>
    
    ## Enable Gzip ##
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    ## enable Gzip##
    
    ## SPECIFY VARY HEADER ##
    <IfModule mod_headers.c>
      <FilesMatch "\.(js|css|xml|gz)$">
        Header append Vary: Accept-Encoding
      </FilesMatch>
    </IfModule>
    ## SPECIFY VARY HEADER ##
    
    <IfModule mod_rewrite.c>
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
  • Luís

    Hi @Samuel,

    I hope had been good today!

    Make a backup of your .htaccess file and try remove the line:

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    If this not solve the issue, can you send me the FTP details of your website?

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.