Moving Multisite to testing Server IP

I am moving a multisite with 18 websites to a VPS.
The VPS has a dedicated IP,. The site domain name has a separate dedicated IP.
Since the live domain is still active, I would like to make changes to the testing server site before we change the DNS pointers.
Therefore, I have replaced the domain name in the tables with the (to be transferred) domain's dedicated IP address, using a global search and replace.
The code sees the database, but we get the message"Could not find site 162.214.0.35. Searched for table wplcb_blogs in database..."
It is searching in the correct database and the table is in there.
Is there a better way to do what I am trying to do?
Thank you.

  • Ash
    • WordPress Hacker

    Hello @John Langlois

    Welcome to WPMU community!

    I hope you are doing good and thanks for asking the question :slight_smile:

    Please check this article: https://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite

    Specially this part:

    If you're moving Multisite from one folder to another, you will need to make sure you edit the wp_blogs entries to change the folder name correctly. You should manually review both wp_site and wp_blogs regardless, to ensure all sites were changed correctly.

    Also, manually review all the wp_x_options tables and look for three fields and edit them as needed:

    home
    siteurl
    fileupload_url

    So, wp_site, wp_blogs and wp_x_options need to check.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • John Langlois
    • Design Lord, Child of Thor

    Ash,
    Thank you for the prompt response.
    I replaced the domain name with the ip address in each of the tables you mentioned, but results are the same.
    Oddly, if I define multisite, false, the login page appears.
    However, when I log in, the page says I do not have permission to view it.
    I suspect there's value getting casually handed off in the code.

  • Ash
    • WordPress Hacker

    Hi there

    Is this what you see when you enter the IP in the browser? (screenshot attached)

    If yes, would you please enable debug mode and check if any error is shown in that page?

    To enable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', false);

    to

    define('WP_DEBUG', true);

    Please let us know what errors you see there.

    Have an awesome day!

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.