Moving website via snapshot backup

Hello. I have been trying to import a backup from another site via snapshot. I have the two files in my folder, and a scan says that it can see the backup. But then nothing happens? How can I "launch" the backup on my new site? Thank you.

  • Rupok

    Hi CInnov,

    Thanks for asking. Can you please tell us what are the names of your two files and in which folder are those stored?

    I'm asking this because if your backup zip name structure is like "snapshot-xxxxxxxxxx.zip", then you will need to login to your target site WordPress dashboard and then go to "Dashboard > Snapshot > Import" section and then set the path of the folder where those snapshots are stored. Then you will need to click on the "Scan/Import Snapshots" button. It will import those snapshots in your All Snapshots section and will be available to restore.

    But if your file name is like "full_backup-xxxxxxxxxxx.zip", and "snapshot-installer.php", then you will need to place those two files in the root directory of your target site. Then you will need to go to "yoursite.com/snapshot-installer.php" and follow the instructions shown on that page.

    Please let us know which one is your backup file name structure.

    If the first one is your case, then I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • CInnov

    Hi, thank you. My two files have the correct names per your above, but when i visit the link, it says it failed:
    PHP Zip module not found. To unpack the zip file, Snapshot needs the Zip module to be installed and enabled. If you use a managed host, contact them directly to have it updated. I was able to extract both zipped files manually into the folder, so I know they're unzipped.

    I have granted support access, thank you

  • Rupok

    Hi CInnov,

    Thanks for sending details. Actually when you unzip graphically through your cPanel file manager and unzipping through PHP are not the same process. When you restore your snapshot through that snapshot-installer.php page, it tries to unzip that file with PHP. That's why PHP Zip module is required to successfully run the restoration process.

    Now, to fix this issue, can you please talk to your host regarding this and request them to install and enable PHP Zip module for you? They can help you best in this.

    Please let us know how the restoration goes after enabling the PHP Zip module. If this doesn't resolve the issue, we will be glad to help further.

    Have a nice day. Cheers!
    Rupok

  • CInnov

    Hi. Ok, I've worked with my hosting service to enable PHP. Problem now is that my configuration failed?
    Configuration
    FAILED
    The first step is to connect to your database. By default we recommend creating a new database, but you can choose to overwrite an existing database once you've tested the connection.

    CONNECT DATABASE

    Database Host Port
    Database Name
    Database Username
    Database Password
    SETTINGS

    New Site URL
    Connect to Server CONNECTED
    Connect to Database CONNECTED
    Database Check

    WARNING
    A database with this name already exists. By proceeding we will wipe and overwrite all existing data. We recommend creating a new database instead.

    RE-TEST CONNECTION

    Am I trying to connect to my new hosting or to the old?

  • Ken Kimbrell

    Hello Clnnov-

    Working alongside Rupok Here. Happy to help!

    First I would like to try an alternate access to your site...
    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Ken Kimbrell"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    -Snapshot Link
    Provide a google drive link to the snapshot archive file so I can gain access to it please.
    ------

    Take Care,

    Ken - WPMU DEV Support

  • Rupok

    Hi CInnov,

    So sorry for the delay from our end and I do apologize for this. We try to reply older threads first but every time you put a reply, your thread becomes a fresh new one and goes down below in the queue. However, we will try to make sure that you get faster responses.

    I assume, http://www.ge********all.org/ is the site where you are trying to restore your backup. If yes, then at first, download all the files from the root directory of that domain except those two backup files. Then create a new database on your server. Then again go to "http://www.ge***********all.org/snapshot-installer.php" page and enter the new database credentials in the Database Name, Database Username, Database Password boxes and then click on the "RE-TEST CONNECTION" button.

    If your database credentials are correct, then the configuration will pass and the deploy section will be shown and you can restore your backup there.

    If you think this is too complex for you, we can try to do this for you. But for doing this, we will need your cPanel login credentials. In that case, can you please send me a message with your cPanel access credentials through our secure contact form here: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: "Attn: Rupok"
    - cPanel Username
    - cPanel Password
    - cPanel Login URL
    - Link back to this thread for reference
    - Any other relevant URLs

    The subject line ensure that it gets assigned to me.

    Please confirm. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi CInnov,

    Thanks for sending the credentials. I was getting the same issue as you mentioned. But then I deleted the backup file from your server, downloaded the backup from the dropbox link you provided, and then reuploaded on your server.

    This time all options were green and I tried to restore. Unfortunately your server provided 500 Internal Server Error and the process stopped.

    As you are in a hurry, I then manually restored the complete site on your server by extracting the backup archive, creating a new database on your server, and then imported all the SQL files from your backup archive to that database and manually changed the "wp-config.php" file with new database credentials.

    Now your site is totally migrated and working fine on the new location. Can you please check and confirm?

    Please let us know if you have any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi CInnov,

    Thanks and sorry for the inconvenience. I was getting a weird redirection issue on your site and to fix that, I had to reset your admin account password and login to your dashboard.

    I tried to login to your dashboard but when I enter proper login credentials, it's telling me to check my email for confirmation. This was not on your site last night. So I guess, you could get access to your site by now.

    However, to check this, I again changed the login credentials. The currently working login credentials are to you over email. Can you please check?

    Please let us know if this doesn't work for you. We will be glad to reset it for you again.

    P.S. Reset Password link is working fine on your site, I just checked. Am I missing anything?

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.