MP3 files not playing in front but are in back end

The mp3's that are uploaded to my blog aren't playing or downloadable as they should be. They play in the back end, but not the front end. Can you please tell me what is happening? I've asked BlueHost if they can sort it their end but they said this: "This issue does not seems to be related to the server instead issue seems to be related to coding or site design. So contacting word press or a developer is best recommended"

Here's an example... scroll to the bottom and you will see that neither track is accessible.... http://www.sacredhypnogoddess.com/kali-ma-and-the-transformative-power-of-her-fire/ and here http://www.sacredhypnogoddess.com/your-meditation-treasure-chest/ - I'm sure this one used to work.... It's been up for months and I must have checked it?! Please help!!

I have switched a different theme and that has same issues. I'm uploading mp3 files straight to media and then inserting as a link

  • Luís

    Hi @awaken,

    Hope you're doing well today!

    I think you have an issue with the Media Protection add-on of Membership 2 Pro.

    Can you send us the FTP details of your website, so we can investigate it further?

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Cheers, Luís

  • Kali Carmel

    Luis - thank you, that is exactly what has happened... I've deactivated that plug in for now and everything works fine. I just activated that the other day, without knowing what it really does.... sounded good. But I'll leave that off for now?!

    Also I don't use FTP so I'm not sure what info I would give you to investigate further anyway. I did give you access thru my dashboard....

    Thank you though, deactivation of media protection is fine with me for now.

    :slight_smile:

  • Kali Carmel

    So far I'm just uploading file directly thru media on WP...... I can get into cpanel, I think, but I'm not so sure what to do once I'm in there...

    But I'm wondering if I can get some help with completing the set up of SacredHypnoGoddess.com as a membership site. I'm real close Its been a huge learning curve getting this far on my own.... but now I'm just having a bit of hurdle at each step and I'm running out of time and not totally sure the best way to go about it.

    I want my blog to be a free membership.... and then I have an online 6 week course I'm going to be offering start of May which I want to be a paid membership. The rest for now is open to all.

    Currently I have a mail chimp newsletter sign up happening for a free treasure chest of mp3 downloads but I'm not sure if that should stay the way it is it if it should be amalgamated with the blog - which I'm tending towards. I don't understand why I'm getting protected content pages showing up without the registration option and other little things that are taking me way to long to figure out.

    I'd also like to activate and use the newsletter plugin. But while the actual sending of a newsletter seems way more streamline, I'm not sure the benefits of that over mail chimp that I am currently using, so far as list growth goes.

    And then I get confused about whether that means I'd then have three lists of the same people, being membership auto responders, newsletter and mail chimp.

    I need to also integrate instant teleseminar for the course. And I'm wondering if I need the course pro plugin that I have or if simply using pages is a better way to go this time. Which also means I need to check that PayPal as my payment gateway is set up right....

    I wanted this all complete by the end of this month so I can get on with promoting the course. It's all there, it just needs connecting together.

    So I'm wondering if there is a way someone can work directly with me using this membership to achieve the above or how I would best go about it... even just having someone sayin "yes what you are trying to do works" would be good to know?!

    I'm just fishing for ideas as to how I can complete this set up efficiently from here.... any advice, guidance, support etc, much appreciated.

  • Luís

    Hi @awaken,

    Hope you're doing well today!

    I think the best option is split all the issues/doubts you have by parts.

    Firstly, regarding to the access to your website, if you can send us the cPanel credentials, we will be able to access to your files and to investigate further your issue. So, please, send the cpanel credentials (link to access, username and password) as mentioned in my previous reply:

    https://premium.wpmudev.org/forums/topic/mp3-files-not-playing-in-front-but-are-in-back-end#post-1034511

    Before we deal with the newsletter question, what pages are you getting the protection message, where everyone is supposed access?

    Just a brief note regarding to CoursePress Pro, this plugin allows you to create complete separeted by units, with interactive questions, forums, chat, assessments, etc.

    Also it can be used alongside with Membership 2 Pro, you can protect your courses and give only access to your members:

    https://premium.wpmudev.org/project/coursepress-pro/

    Cheers, Luís

  • Kali Carmel

    Ok... lets do one thing at a time... support access is open in the back end... I'm happy to supply cpanel access as well via the "different question" process....

    But for now I would love an answer to this -

    Regarding Membership... I am first of all creating a free membership which will include just my Blog.... Secondly I am creating a Paid Drip Feed Membership that will include a six week course @ $97 early bird and $157 full price....

    When I go Membership2 - Protection Messages.... I have activated "Define Custom Message" and have put the custom message I want to appear under "Content protection message".... But no matter what short code I put on the page that appears under this link: http://www.sacredhypnogoddess.com/protected-content/ I only seem to get - the short message that says 'you have to be a member to be here' - nothing of my custom message appears....

    SO... I edited the page from there and put in what I want it to say.... and I know that it is going to say the same thing now when the paid membership is up and running... but it will need it's own custom message....

    Please tell me what I am missing here so I can remedy this. I think part of it is that I don't understand how the shortcodes work under the memberships list... and now I've deleted the one from the protected content page because it wasn't saying what I wanted it to. Its working fine with only the Blog page as a menu item that links to protected content, but once there are other pages for the paid membership, it won't be as clear for the visitor... unless I edit the page to address both memberships which seems messy and unnecessary... please help?! I hope this make sense?!

  • Luís

    Hi @awaken

    Hope you're doing well today!

    I tried to access to your admin panel using Support Access, but I was unable, can you re-enable it?

    However, if you already added a custom protection message in the membership, try add this code to your wp-config.php, to see if your custom message is displayed:

    define( 'MS_PROTECTED_MESSAGE_REVERSE_RULE', true );

    If you are using the protect content shortcode, you can define a custom message there:

    [ms-protect-content id="1" msg="individual protection message"]Only members of membership-1 can see this![/ms-protect-content]

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.