multi-db problem - "The site you have requested is not installed properly."

Hi.

After much messing around the last couple days,
I was able to get multi-db working

(see thread)

But I guess it's not really working.
Last night, it seemed to be fine,
but when I tried creating sites this morning...
no luck.

I cannot create them from the front end or back end.
I'm receiving this error:

"The site you have requested is not installed properly. Please contact the system administrator."

Or if I try to access the page directly after the signup,
the link points here:
http:///

And I receive this error in a java popup:
"The URL is not valid and cannot be loaded."

My sql user has all privileges.
Here's the check message:

GRANT ALL PRIVILEGES ON *.* TO 'DB'@'%' IDENTIFIED BY PASSWORD '*PASS' WITH GRANT OPTION

Here is an excerpt of my 4096 DB config file:

<?php
//	Plugin Name: Multi-DB
//	Plugin URI: https://premium.wpmudev.org/project/Multiple-Databases
//	Author: Andrew Billits (Incsub), S H Mohanjith (Incsub)
//  Version: 2.9.2
//------------------------------------------------------------------------//
//---DB Scaling-----------------------------------------------------------//
//------------------------------------------------------------------------//
//	16,256,4096
define ('DB_SCALING', '4096');
//------------------------------------------------------------------------//
//---DC IPs---------------------------------------------------------------//
//------------------------------------------------------------------------//
//	Usage: add_dc_ip(IP, DC)
//	EX: add_dc_ip('123.123.123.', 'dc1');
add_dc_ip('IP', 'dc1');
//------------------------------------------------------------------------//
//---Global Tables--------------------------------------------------------//
//------------------------------------------------------------------------//
//	Do not include default global tables
//	Leave off base prefix (eg: wp_)
//
//	Usage: add_global_table(TABLE_NAME)
//	EX: add_global_table('something');
add_global_table('homewo_global');
add_global_table('supporters');
add_global_table('supporter_signup_stats');
add_global_table('supporter_daily_stats');
add_global_table('supporter_ads');

//------------------------------------------------------------------------//
//---DB Servers-----------------------------------------------------------//
//------------------------------------------------------------------------//
//	Database servers grouped by dataset.
//	R can be 0 (no reads) or a positive integer indicating the order
//	in which to attempt communication (all locals, then all remotes)
//
//	Usage: add_db_server(DS, DC, READ, WRITE, HOST, LAN_HOST, NAME, USER, PASS)
//	EX: add_db_server('global', 'dc1', 1, 1,'global.mysql.example.com:3509','global.mysql.example.lan:3509', 'global-db', 'globaluser',  'globalpassword');
//
//	Note: you can also place this section in a file called db-list.php in wp-content
//  EX: add_db_server('global', 'dc1', 1, 1,'global.mysql.example.com:3509','global.mysql.example.lan:3509', 'global-db', 'globaluser',  'globalpassword');
add_db_server('global', 'dc1', 1, 1,'IP', 'IP', 'homewo_global', 'USER',  'PASS');

add_db_server('000', 'dc1', 1, 1,'','IP', 'IP', 'homewo_000', 'USER',  'PASS');
add_db_server('001', 'dc1', 1, 1,'','IP', 'IP', 'homewo_001', 'USER',  'PASS');
add_db_server('002', 'dc1', 1, 1,'','IP', 'IP', 'homewo_002', 'USER',  'PASS');
add_db_server('003', 'dc1', 1, 1,'','IP', 'IP', 'homewo_003', 'USER',  'PASS');

EDIT: here's my recent mysql logs-

110904 17:32:04 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
110904 17:32:04  InnoDB: Initializing buffer pool, size = 8.0M
110904 17:32:04  InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file ./ibdata1 did not exist:
InnoDB: a new database to be created!
110904 17:32:04  InnoDB: Setting file ./ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
110904 17:32:04  InnoDB: Log file ./ib_logfile0 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
110904 17:32:04  InnoDB: Log file ./ib_logfile1 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
110904 17:32:04  InnoDB: Started; log sequence number 0 0
110904 17:32:04 [Note] Event Scheduler: Loaded 0 events
110904 17:32:04 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.1.58'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  Source distribution
110905  1:03:25 [Note] /usr/libexec/mysqld: Normal shutdown

110905  1:03:25 [Note] Event Scheduler: Purging the queue. 0 events
110905  1:03:25  InnoDB: Starting shutdown...
110905  1:03:27  InnoDB: Shutdown completed; log sequence number 0 44233
110905  1:03:27 [Note] /usr/libexec/mysqld: Shutdown complete

110905 01:03:27 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

^
I can't really read this thing too well,
but maybe you can make some sense of it.

When I disable multi-db and revert to original settings,
blog creation works fine.

What am I doing incorrectly?
Any help would be appreciated.