Multi-Domain Plugin Update notification error

Hello Guys,
Greetings,
I have had the Multi-Domain installed under MU-Plugin,recently since the new update I've manually deleted it from there and installed the new verison 1.3 manually under PLUGINS as the WPMUDEV dashboard kept showing this was installed.

However although I don't see /experience any problem so far apart from the update notification saying I have 1.2 installed.

I'm going to attach a snapshot on the next message as this one doesn't have any option.

Appreciate your help.
Thanks